Omni.kit.extpath.git issue

Hello folks, I tried to follow the guide Getting Started: Extensions — kit-sdk 103.1 documentation for OV Extension from GIT. Therefore I just created my own repo with the boilerplate provided by NVIDIA (GitHub - OndrejSzekely/metron_ai_ardagen_omni_ext: Metron AI ArDaGen Omniverse Extension). When I add the extension with path git:// it works fine and I can run the extension. However, when close Isaac Sim and run the app again, the app won’t load and throws the error in console:

Loading user config located at: '/ssd_crucial/omniverse/data/Kit/Isaac-Sim/2022.1/user.config.json'
[Info] [carb] Logging to file: /home/ondra/.nvidia-omniverse/logs/Kit/Isaac-Sim/2022.1/kit_20221204_104641.log
2022-12-04 09:46:41 [6ms] [Warning] [omni.ext.plugin] [ext: omni.drivesim.sensors.nv.lidar] Extensions config 'extension.toml' doesn't exist '/ssd_crucial/omniverse/library/isaac_sim-2022.1.1/exts/omni.drivesim.sensors.nv.lidar' or '/ssd_crucial/omniverse/library/isaac_sim-2022.1.1/exts/omni.drivesim.sensors.nv.lidar/config'
2022-12-04 09:46:41 [88ms] [Error] [carb.scripting-python.plugin] ModuleNotFoundError: No module named 'omni'

  PythonExtension.cpp::prestartup()(1): <module>

2022-12-04 09:46:41 [88ms] [Error] [omni.ext.plugin] [ext: omni.kit.extpath.git-0.0.0] Failed to process python module extension in '/ssd_crucial/omniverse/library/isaac_sim-2022.1.1/kit/extscore/omni.kit.extpath.git/.'.
[0.116s] [ext: omni.kit.extpath.git-0.0.0] startup
2022-12-04 09:46:41 [88ms] [Error] [carb.scripting-python.plugin] ModuleNotFoundError: No module named 'omni'

  PythonExtension.cpp::shutdown()(1): <module>

2022-12-04 09:46:41 [88ms] [Error] [omni.ext.plugin] Failed while calling `shutdown_extensions` function: /ssd_crucial/omniverse/library/isaac_sim-2022.1.1/kit/extscore/omni.kit.extpath.git
2022-12-04 09:46:41 [88ms] [Error] [omni.ext.plugin] Failed to add extension path: 'git://'. Local path is empty or scheme is not supported.
[0.207s] [ext: omni.stats-0.0.0] startup
[0.232s] [ext: omni.gpu_foundation-0.0.0] startup
2022-12-04 09:46:41 [209ms] [Warning] [carb] FrameworkImpl::setDefaultPlugin(client: omni.gpu_foundation_factory.plugin, desc : [carb::graphics::Graphics v2.5], plugin : failed. Plugin selection is locked, because the interface was previously acquired by: 
[0.238s] [ext: carb.windowing.plugins-1.0.0] startup
[0.244s] [ext: omni.assets.plugins-0.0.0] startup
[0.245s] [ext: omni.kit.renderer.init-0.0.0] startup

For some reason omni.kit.extpath.git issue have an issue with loading. When I disable omni.kit.extpath.git issue in the config, the app loads. Can you help me?

Hi @ondra.szekely. This seems to be working fine for me in the Code app. I’ve gone ahead and moved this to the Isaac Sim forum.

Thank you @mati-nvidia . Good point, I will test it in Code as well during the weekend and let you know.

@mati-nvidia I tried out and doesn’t work for me either in Code. Did you try it out on Linux or Win? I’m using Ubuntu.

@ondra.szekely , are you still seeing this error?

Hello @rthaker , it wasn’t solved. I tried what @mati-nvidia recommended, but no success. He said, you will test out on your side. I’ve not checked it since then.

Hi - Sorry for the delay in the response. Let us know if you still having this issue/question with the latest Isaac Sim 2022.2.1 release.