Omniverse Create - Crash on playback

Log file contains the following:

nvcuda64.dll
nvcuda64.dll!cuEventSynchronize
PhysXGpu_64.dll!PxSetPhysXGpuProfilerCallback
PhysXGpu_64.dll!PxSetPhysXGpuProfilerCallback
PhysXGpu_64.dll!PxSetPhysXGpuProfilerCallback
PhysXGpu_64.dll!PxSetPhysXGpuProfilerCallback
omni.physx.plugin.dll!carbOnPluginStartup
omni.physx.plugin.dll!carbOnPluginStartup
omni.physx.plugin.dll!carbOnPluginStartup
omni.physx.plugin.dll!carbOnPluginStartup
omni.physx.plugin.dll!carbOnPluginStartup
KERNEL32.DLL!BaseThreadInitThunk
ntdll.dll!RtlUserThreadStart

Oddly enough it was working fine last night.
I can do everything except play the scene.

Thanks for reporting this, Anygiraffe! I’m following up with the team here and will update as soon as we have some info for you.

Hi again! Although crashes can be common at this stage of release (things will improve as we update), we’re having a tough time narrowing down your exact issue. Would you be able to reply with full repro steps, basically detailing each of the interactions with Create until the crash?

Thanks again, Anygiraffe!

I think I’ve narrowed it down to specifically running the blast extension, current version is 0.7.2 kit_100.3. More specifically when I fracture an object with blast and try to play it back to demonstrate the physics.

My process is:
Open Omni Create → create physics scene → create physics ground plane → create material, omniPBR ( applied to ground plane → create mesh (any) → set mesh kind to component → with model (T) mode right click mesh an apply physics rigid body preset → from here I usually play the scene back with no issue to test that the object falls / hits the ground plane.

Interestingly trying this now, the cylinder I made fell slightly, stopped, and now omni create is locked up not responding with the windows spinning wheel as my cursor. However it hasnt crashed to generate a crash log in about 5 minutes, just locked in not responding. Force closing from this stage does not generate a crash log so I will continue up to the point in my process which generates the crash log.

Next I would open the extensions window to load omni.blast → switch to prim mode → select the mesh (cylinder in this case) → fracture object (from blast menu) → debug blast set to 2 or 3 to see the fragments / tweak fragments → play scene. The crash is very similar to what I described above but the program usually closes itself within a few seconds of locking. Object falls slightly then stops, I was able to get it to work and fragment / playback once when I initially opened it, however stopping and playing it again caused it to crash.

It shouldnt be a hardware limitation, am running rtx 3090 and ryzen 5800x cpu with 32gb ram aswell.

Hi Anygiraffe,

I’m one of the leads on the destruction extension. Thank you for reporting this. I’ve logged it in our bug system, but I should mention that we already have logged bugs related to playback with destruction. Even without the crash, playback is simply incompatible with destruction at the moment. We’re in the middle of fixing this now, but the problem runs somewhat deep so it won’t be a quick fix. Once we have it working we’ll ensure it’s doing so on the release branch as well, and of course that there are no crashes!

I’m sorry I can’t give you a definite time frame, but I can assure you we consider this a top priority as recording destruction is something many people want to do.

Thanks again,

Bryan Galdrikian

Hi @Anygiraffe, I’m also on the destruction team and just tried following your steps, but wasn’t able to reproduce the crash. I think Bryan may have misunderstood what your problem is - were you using the omni.recorder extension or just starting simulation with the play button? We’ve been trying to fix issues recording simulation with the omni.recorder extension, but regular simulation should work.

Could you please explain a bit more what you mean by “tweak fragments”? If you have the ability to record a video of your steps, that would be really helpful to make sure I didn’t miss anything. Or could you at least please screenshot the Blast:Fracture Controls panel so I can make sure my settings match yours exactly?

Thanks for the help tracking down the issue here, hopefully we can get it sorted quickly for you.

Hi @Anygiraffe,

I just wanted to check in on this issue. I’m sorry there’s been no response in this form for a while. The omni.blast extension has been undergoing heavy development, as we push forward to our general release. The latest published version for the Create beta is 0.8.2, which has a fair number of improvements and bug fixes over 0.7.2. Specifically, I could not reproduce the crash you reported in 0.8.2.

I hope this resolves some issues for you!

Bryan Galdrikian