Omniverse Drive Connection to Remote Machine : "Error: Connection"

Hi, I’m trying to set up a proof of concept with Omniverse and I’m unable to connect to Drive from a remote machine. The host server has Nucleus set up, and I can connect via Drive on that machine (locally). I am now trying to connect to the server from a remote machine. I’ve tried connecting Drive via IP address and machine name and neither seems to be working. My connection string is :3009. I am able to ping the server, so I know it’s visible to my client, and I have tried shutting off the entire firewall software on the server to make sure that’s not the issue.

Every time I attempt a remote connection, I get the error: “Error: Connection”

Ideas? Are there log files I can look at on the client/server to get more info? Thanks.

Hi, jonwhite135 - sorry for the trouble. It could be a firewall issue… you will also need to prefix the :3009 with the IP address of the server… for example, 192.122.1.1:3009

To help troubleshoot would you like to set-up a time to jump on our Discord? You can join here: https://discord.gg/XWQNJDNuaC

Cheers,
Edmar
Discord ID: Prof E#2041

Omniverse Resources:
Open Beta | Documentation | Tech Requirements | Videos | Roadmap | Twitter | Discord

PLEASE NOTE: If you are reporting a bug/issue, please provide OS, GPU, GPU Driver, the version of the app, and full log file (if applicable).

1 Like

Ok, so a few quick questions…
When you say you are plugging in “:3009” do you mean you are plugging in the ip + “:3009”? Because this is what you should be doing. The ip of the host must prefix the :3009. for example 192.192.1.1:3009 is a “valid” address. Just make sure the ip used is the ip of the server.

IF that is how you are doing it, then you will likely be hitting firewall issues either in your OS firewall or in your Router firewall. Ill watch and reply after you reply.

2 Likes

Thanks. I have prefixed the IP address and machine name and have had no luck. (For some reason, in my note, the machine name dropped from the post…)

I’ll do some more troubleshooting if you are quite sure it’s a firewall issue, and get back to you if I continue to have no success. Thanks -

I would take a look at this page.

https://docs.omniverse.nvidia.com/prod_nucleus/prod_nucleus/usage/workstation.html#port-configuration

It will give some clues as to what ports are needed to be opened. If you are using a home router, they can often be locked up pretty tight. Also, do not discount the firewalls on your pc. They too get pretty tight and can block a lot.

1 Like

Have you tried to connect to the omniverse web capability? You should try that too. See if you can even http to it.

ip + “:8080”

1 Like

I tried accessing 8080, and that didn’t work either. I’ve tried opening up the firewall as wide as possible / turning off, also to no avail. I don’t believe the router is an issue.

So I set up a server on the client as well. Now I have two servers, one on each end. From within each server, I have no issues connecting to “localhost:port”. From each server, I am unable to connect across to the other. I am able to ping from each side, so each can be seen from the other.

On each local machine, I can access the apps using “localhost:port”, but if I attempt to access using it’s own machine name or IP address, it does not work. It seems I should be able to do this, but maybe I’m wrong – or maybe this is helpful with troubleshooting.

It honestly sounds to me like a router issue (ports need to be allowed). With that said, ill see if i can have someone else take a look at this thread. maybe they might have some suggestions.

Ok, i’d like you to try this on your host. I should have recommended this first.

  1. Open up Launcher
  2. Select the Collaboration Tab
  3. Next to the “Local Nucleus Collab Services” heading bar, there is a tripple bar (hamburger) icon. Click it and select Settings. This will launch you into System Monitor
  4. In System Monitor, at the very top, there is a button for Sharing.
  5. Click it on.

Try to connect now or lemme know if that was already checked on for you.

2 Likes

Magnificent! That fixed it. I may need to make some firewall tweaks - haven’t gotten that far - but that solved the issue. No, it was not checked on by default for me. Thanks for the help!!

2 Likes