Omniverse Extremely Slow When Running Isaac Sim

I’m trying to run Isaac Sim in Omniverse and I can get it to launch but it is extremely slow to the point where it is almost unusable. When I initially launch it, it shows my GPU (Quadro RTX 8000) in a table inside the command terminal and next to it says “Yes: 0” under the “Active” column. Immediately after the table is displayed there is an error which says “[Error] [carb.glinterop.plugin] OpenGL Interop is not available. Upgrade your driver to latest for this feature.” However, I already have the latest NVIDIA drivers installed (516.94). I have confirmed it is the latest by looking on the NVIDIA website and also by trying to automatically upgrade it in the Device Manager. I know the GPU works because it works as expected when running 3DS Max. I am on Windows 10. Any help would be greatly appreciated. Thank you.

@robotinfo2022 do you see the same issue when running other omniverse apps like Create?

Yes, it is still slow though Create seems to run a bit smoother than Isaac Sim. Since posting this I changed my Nvidia driver to 471.41 and it removed that error but there was no improvement in performance and it still says “Yes: 0”. It seems like my GPU is not being used when the program is running. I have also seen a drastic drop in GPU usage when it launches. I should also mention I am connecting to the workstation remotely through VNC.

I see, so I can see your GPU configuration and compare with create, can you attach:

  • a log file from create
  • a log file from isaac sim
  • the output of nvidia-smi

Here are the requested files:
Create_log.txt (1.0 MB)
Isaac_Sim_log.txt (1.1 MB)
SM-nvidia-smi

Nothing looks immediately suspicious…

What VNC client? and can you use the native windows remote desktop client instead?

What FPS do you get in the viewport?
(if its not visible you can click the eye icon in the viewport and turn on the fps hud stat)