Omniverse Kit Scripting bug

Hello. I have some bug with omniverse kit scripting. When i working on omniverse kit scripting with omniverse create app, it returns errors in below even there have no syntax error in source code. But scripts works well after restart omniverse app.

2021-11-18 09:42:34 [Error] [carb.scripting-python.plugin] BrokenPipeError: [Errno 32] Broken pipe

At:
/home/cimr/.local/share/ov/pkg/deps/4a4ac5b063f92375d0d74eb0f2c3ac9b/plugins/bindings-python/omni/kit/app/impl/init.py(91): write
/home/cimr/Documents/Omniverse/Custom_kit/exts/omni.collider.humanoid/omni/collider/humanoid/extension.py(30): on_startup
/home/cimr/.local/share/ov/pkg/deps/4a4ac5b063f92375d0d74eb0f2c3ac9b/plugins/bindings-python/omni/ext/impl/_internal.py(141): _startup_ext
/home/cimr/.local/share/ov/pkg/deps/4a4ac5b063f92375d0d74eb0f2c3ac9b/plugins/bindings-python/omni/ext/impl/_internal.py(174): startup_all_extensions_in_module
/home/cimr/.local/share/ov/pkg/deps/4a4ac5b063f92375d0d74eb0f2c3ac9b/plugins/bindings-python/omni/ext/impl/_internal.py(225): startup_all_extensions_in_module
PythonExtension.cpp::startup()(2):

Hello @tdain721! I’ve informed the dev team to help you with this issue. Thanks for reaching out to us!

Hi, thanks for the report. I saw that before too, but not sure what is going on. Basically we just do sys.stdout.write there and at some point file descriptor may become invalid. It could matter if you run it from windows terminal or not. Please let us know if you find out anything else.