Omniverse Launcher resets start up application status on reboot

The Omniverse Launcher appears to be resetting my start up application settings on reboot. I installed the Launcher and it started on the next reboot, so I went through Windows Startup application settings and turned it off. That worked for one reboot, but it came back the next reboot. I’ve turned it off on start up, rebooted, then checked the settings and it’s enabled again. I’d really like it to respect those settings since I don’t use Omniverse related applications regularly and don’t need it to start after a reboot.

OS: Windows 10 Pro

Repro steps:
Install Omniverse Launcher
Navigate to Windows Startup Apps and toggle Nvidia Omniverse Launcher to off
Navigate to Windows Startup Apps and note that Nvidia Omniverse Launcher is toggled on again.

Hi @archer-kgraves. Can you try unchecking this?