Omniverse login confusion/problem

Running omniverse either local or headless, but login fails on omniverse.
Running nucleus server and can access it with the web ui (either admin or omniverse) and unable to add Isaac folder from root… what am I missing here?

The current Nucleus Server does not support passwords. You can only login with the same username as password. If you have accidentally entered a password try another username and use the same password as username.

You can create the Isaac root folder in Isaac Sim instead of the web-ui for now. See Step #6 here.

still confused. Tried the Step 6 again, but am getting login failed. Where might i have set the password?

Hello wegunterjr
for me the following worked:
lock in on Nucleus Server with username: omniverse
lock in Omniverse Isaac Sim : Username: omniverse Server: localhost:3009
then i could create the Isaac Folder
hope this helps
Kind Regards

1 Like

What order do you start your systems?
According to the instructions pages, Omniverse is running before launching Nucleus server… right?

The Nucleus Server needs to be running before connecting to it using Isaac Sim or the Web. Could you please provide the steps to took when getting the login failed message?

also, i am now not able to login

I am following the steps outlined Installation instructions

  1. make sure i run xhost +local
  2. do the local docker run
    sudo docker run --entrypoint ./runapp.sh --gpus all -e "ACCEPT_EULA=Y" --rm -v /tmp/.X11-unix:/tmp/.X11-unix -v /etc/localtime:/etc/localtime:ro -e DISPLAY=unix${DISPLAY} nvcr.io/nvidia/isaac-sim:2020.1_ea
  3. start nucleus Nucleus Deployment

then try to login to nucleus using: omniserve (but now it is won’t even connect to the server - maybe i broke something? HA!

Then from omniverse local, I try to login and it fails too…

also, is there a problem with running the Nucleus Server script more than once?

./omniverse-nucleus-2019.3A.2282-1-linux-installer.run

seems like i have multipler services running…

root 901 0.5 0.0 0 0 ? S 10:35 0:07 [nvidia-modeset/]
root 902 0.0 0.0 0 0 ? S 10:35 0:00 [nvidia-modeset/]
root 903 1.2 0.0 0 0 ? S 10:35 0:19 [irq/206-nvidia]
root 904 0.0 0.0 0 0 ? S 10:35 0:00 [nvidia]
nvidia-+ 1400 0.0 0.0 17324 1976 ? Ss 10:35 0:00 /usr/bin/nvidia-persistenced --user nvidia-persistenced --no-persistence-mode --verbose
omniver+ 7161 0.0 0.0 1769248 39496 ? Ssl 10:58 0:00 /opt/nvidia/omniverse/server/omni.server.app -input false
omniver+ 8846 3.2 0.0 30096 22772 ? Ss 11:00 0:00 /opt/nvidia/omniverse/snapshot-service/OmniverseSnapshotService
omniver+ 8890 3.3 0.0 30096 22708 ? Ss 11:00 0:00 /opt/nvidia/omniverse/thumbnail-service/create_thumbnails
omniver+ 8903 1.0 0.0 115004 28660 ? S 11:00 0:00 /opt/nvidia/omniverse/snapshot-service/OmniverseSnapshotService
omniver+ 8947 2.0 0.0 217004 32620 ? Sl 11:00 0:00 /opt/nvidia/omniverse/thumbnail-service/create_thumbnails
omniver+ 9030 4.7 0.0 30100 22896 ? Ss 11:00 0:00 /opt/nvidia/omniverse/web/OmniverseWeb
omniver+ 9079 14.5 0.0 30112 22964 ? Ss 11:00 0:01 /opt/nvidia/omniverse/asset-converter/OmniverseAssetConverterService
omniver+ 9101 2.5 0.0 135660 32580 ? S 11:00 0:00 /opt/nvidia/omniverse/web/OmniverseWeb
omniver+ 9109 0.0 0.0 135660 27284 ? S 11:00 0:00 /opt/nvidia/omniverse/web/OmniverseWeb
omniver+ 9118 1.8 0.0 607688 53220 ? S 11:00 0:00 /opt/nvidia/omniverse/asset-converter/OmniverseAssetConverterService

I think it’s fine running the same installer again. That log looks fine.
Try running systemctl status omniverse-server to see if the server is active.

   Active: active (running) since Tue 2020-08-25 10:58:30 MDT; 33min ago
 Main PID: 7161 (omni.server.app)
    Tasks: 46 (limit: 4915)
   CGroup: /system.slice/omniverse-server.service
           ├─7161 /opt/nvidia/omniverse/server/omni.server.app -input false
           └─7204 ./omni.delta-server.app -input false

Aug 25 10:58:30 roboubuntu-Adder-WS omni.server.app[7161]:     "omni.server.app": {}
Aug 25 10:58:30 roboubuntu-Adder-WS omni.server.app[7161]: }
Aug 25 10:58:30 roboubuntu-Adder-WS omni.server.app[7161]: 2020-08-25 16:58:30 [2ms] [Info] [omni.server] Logging enabled for channel: omni.server.BENCHMARK
Aug 25 10:58:30 roboubuntu-Adder-WS omni.server.app[7161]: 2020-08-25 16:58:30 [2ms] [Info] [carb] Initializing plugin: omni.websocketslib (interfaces: [omni::server::IWebSockets v1.0]) (impl: omni.websocketslib)
Aug 25 10:58:30 roboubuntu-Adder-WS omni.server.app[7161]: 2020-08-25 16:58:30 [2ms] [Info] [omni.server] ServerVersion: 107.6.1553.b90f063b
Aug 25 10:58:30 roboubuntu-Adder-WS omni.server.app[7161]: 2020-08-25 16:58:30 [2ms] [Info] [carb] Initializing plugin: omni.resolver (interfaces: [omni::IResolver v2.1]) (impl: omni.resolver)
Aug 25 10:58:30 roboubuntu-Adder-WS omni.server.app[7161]: 2020-08-25 16:58:30 [3ms] [Info] [carb] Initializing plugin: omni.keyvaluedatabase.leveldb (interfaces: [omni::server::IKeyValueDatabase v1.0]) (impl: omni.keyvaluedatabase.leveldb)
Aug 25 10:58:30 roboubuntu-Adder-WS omni.server.app[7161]: 2020-08-25[2020/08/25 10:58:30:0883] WARN: getpeername: Transport endpoint is not connected
Aug 25 10:58:32 roboubuntu-Adder-WS omni.server.app[7161]: [2020/08/25 10:58:32:0907] NOTICE: Creating Vhost 'default' port 3007, 1 protocols, IPv6 off
Aug 25 11:00:32 roboubuntu-Adder-WS systemd[1]: omniverse-server.service: Current command vanished from the unit file, execution of the command list won't be resumed.

looks like it is running, i can login now (had to stop some PID’s… strange. )

  • I logged into Nucleus Server http://localhost:8080/
  • started Omniverse Isaac Sim - and cannot login with omniverse - ERROR: Connection Failed

If i try to login with admin or omniverse, it still says ERROR: Connection failed in the ISaac Sim…
If I leave username empty, it shows ‘COnnecting’ at the bottom of the login gui, but …never logs in…and the only to fix it is to stop the docker.

Ok, looks like you got the connection working via the Web-UI but not the container. It’s probably needs some ports open on the container. Please try the --network host flag when running the Isaac Sim container.

1 Like

i did --network=host and added it right before the ports
sudo docker run --gpus all -e "ACCEPT_EULA=Y" --network=host --rm -p 47995-48012:47995-48012/udp -p 47995-48012:47995-48012/tcp -p 49000-49007:49000-49007/tcp -p 49000-49007:49000-49007/udp nvcr.io/nvidia/isaac-sim:2020.1_ea

Yes, running sudo docker run --gpus all -e "ACCEPT_EULA=Y" --network=host --rm nvcr.io/nvidia/isaac-sim:2020.1_ea should work. How about trying a reboot?

Is your Nuclues server installed natively on the same machine and not in a container?

Oh sorry… Your suggestion worked!! I added the network=host and boom! Working. Now to see why it is running my CPU at 100%.

1 Like

Nucleus is native.