Omniverse menu doesn't show up in ARCHICAD

Hi,

I have installed the ARCHICAD connector, the View app and a local Nucleus server, but I don’t see the Omniverse menu in ARCHICAD. I have ARCHICAD 24 build 5000. What should I do?

Hello @leroystreetstudio. We sometimes run into this issue. usually uninstalling, rebooting, and then re-installing the connector fixes this issue. Please go ahead and try this and report back. Thanks!

Hi @FViloria I was running into the same problem and followed your instructions and did not get any results. I there anything else I can do or any of the processes changed within this time? Cheers!

I have the same Problem, previously whas working fine, but, I had to restore my computer, in the re-install procces the tab doesnt show up anywhere.
I uninstalll all the programs and nothing works.

Hello @danichazez! Welcome to the Community! Would you be able to give me some more information so that we can help troubleshoot the issue?

System Information

  • Operating System

  • GPU & GPU Driver

Omniverse Information

  • Applications Used & Version Numbers
  • Console Logs
  • Omniverse Logs: C:\Users\<USERNAME>\.nvidia-omniverse\logs
  • Connector Logs: C:\Users\<USERNAME>\Documents\Omniverse\<CONNECTORNAME>

Helpful Troubleshooting Tools

Windows 10 Pr, 64-bit
Nvidia Geforce RTX 3080 Version del Controlador: 471.96

Archicad 24 and Archicad 25, both not working.
Omniverse,
View 2021.3.2
Cache 2.4.6
Conector Graphisoft Archicad 103.1.92

Hello, a ticket was created to document each stage of resolving the ArchiCAD Omniverse menu not showing issue. Ticket: OM-37138. Thank you all for your patience.

The new version of the Archicad Connector is available, version 103.1.93
Please try installing this new version.

Note: At this time, only Archicad 24 is supported

After installing, if the Omniverse palette still does not display, please check the Path in your system variables. You should see a path similar to this (drive letter and username may be different):
C:\Users<username>\AppData\Local\ov\pkg\archicad-connector-103.1.93

In the Registry, you should see an entry similar to this:
Computer\HKEY_CURRENT_USER\SOFTWARE\GRAPHISOFT\ARCHICAD\ARCHICAD 24.0.0 USA R1\Add-On Manager\Include
#1 lan.flat:///C:/Users//AppData/Local/ov/pkg/archicad-connector-103.1.93/OmniArchicad.apx

If either the path or the registry entry are not correct, please add a new comment to the forum.

Any release notes for the latest build. Are the materials export supported???

Materials are supported via a mapping mechanism.

We look at the name in Archicad and then map it to an existing material (MDL) in Omniverse. This map can be modified and updated.

If you look in Revit documentation (Revit — Omniverse Connect documentation) and scroll down to the Materials section, you’ll see an explanation of the formatting of the file.

In /Omniverse/Archicad, you will find omniverseMDLtable.csv.

It looks like this:

First column is the Archicad material name. If we find a match, then we map it. If not, we’ll add materials not found as EXCLUDEd items at the end of the list, like this:

Second column is the mapping mechanism:

  NONE - default, means that we look for an exact match between the name in Column A and the name we get from Archicad for the object
  EXCLUDE - we ignore the mapping but it's recorded here so you can modify it and tells you what materials we have encountered during exports.
  COLOR - this also is an exact match but then we take the color of the object to change the tint of the MDL shader (see the keyword **diffuse_tint** which is added to Column E when this is used)
  GENERIC - this looks for a partial match and these are looked at after all of the NONE/COLOR entries have been checked first. So, a name of **glass** would match Glass, Glass_Window, Blue_Glass, etc.

Note that the CSV is currently read in during the first export of the sessions. If you change the CSV, you need to restart Archicad to see the effects. This will be changed soon so you don’t need to restart Archicad.

This mapping always tries to take place. So, if you have white materials then it’s probable that it is not matching to any materials in your model.

Brian

Thanks for the info.
Ideally the materials should be mapped automatically without any editing from the user.
Several times we change the names materials, we add new ones, we delete others, so all this process has to be updated in the platform, like changing objects. Otherwise the workflow is not optimized on an architectural basis.

So we wait for the next release where everything will be automatic!!! We hope…