Omniverse refuses to download any app

Hi there. I’ve just downloaded and installed the free version of Omniverse launcher. However, I am unable to download any builds, apps, materials, etc. I click the ‘Install’ or ‘Download’ button, it turns grey for a few seconds, and then stops. No matter how many times I click the button, the item in question refuses to download or install. I’ve tried running in Administrative mode but no luck. Could the issue have to do with my company’s firewall or security policies? I’m not receiving any error messages or popups, simply just refusing to install/download.

I’m on the latest build of Windows 10, Intel i9 12900KF processor and Nvidia RTX 3090Ti with latest Studio drivers.

Thanks,
Philip

Hi @philip.gedarovich! Could you attach a copy of your launcher log files? They are usually found here: C:\Users\<USERNAME>\.nvidia-omniverse\logs\launcher. Hopefully they will indicate what the issue is!

launcher.log (46.4 KB)

Hi Wendy, thanks for your response. I’ve attached the log file. Hope this will help solve the problem!

Hmm, I will need to send your log over to the dev team. The error looks like it is “Unable to get local issuer certificate”. I’ll see if they have any suggestions for this.

I am having a similar issue. App fails to download with error given below but I am able to download the package.zip if I copy/paste the URL in chrome browser on the same windows server.

Error occurred during installation of View: request to https://asset.launcher.omniverse.nvidia.com/view/2022.1.3/windows-x86_64/package.zip?Expires=1659520624&Policy=eyJTdGF0ZW1lbnQiOlt7IlJlc291cmNlIjoiaHR0cHM6Ly9hc3NldC5sYXVuY2hlci5vbW5pdmVyc2UubnZpZGlhLmNvbS92aWV3LzIwMjIuMS4zL3dpbmRvd3MteDg2XzY0L3BhY2thZ2UuemlwIiwiQ29uZGl0aW9uIjp7IkRhdGVMZXNzVGhhbiI6eyJBV1M6RXBvY2hUaW1lIjoxNjU5NTIwNjI0fX19XX0_&Signature=EBxXRugM8O~uR8Tgoniyna5zCSJc2Q~o04jG~2IDMsQqYFEgvnEZUsPzAR5XdLC424V6~DFTcQOka59EkldyBHdVuUmTfutE6pA2usoOShr1bAJ5AB2p2gIcp-Py7sBY16XwmlT7V0RQWCdEEDwa9YVOZckOX-cRl2xmwcp3FTDciIKNpSReE1nrQMJIRMLPNqvFAJ4LikeLZz5NnarxW6nIaLfbWCGB64WfJgLzgnCb7p0lkGZhn2wcQ6lGDguu-AX9aISueFOVHwBsWiEorxabZSBEcyR8wy-AbbkIalwzjoQTguayDqHo7vvaqrsKYuvkyyotoTeRZxeCbCWUbg__&Key-Pair-Id=K13PD0MHC2KFRP failed, reason: unable to get local issuer certificate

Hello @philip.gedarovich! From your logs, it looks like maybe your company’s IT department is blocking access to S3.

Thanks Wendy, I figured it had something to do with my company’s firewalls. I’ll escalate this to the IT department. In the meantime, is there an alternate way to download and install content out of the Launcher app?

Hi @philip.gedarovich! I am asking around, but as far as I know there isn’t an alternative way to install content from the Launcher. I will post back when I find out more information!