Omniverse XR - Blurry VR Scene

Hello,
the VR Scene appears to be very blurry in the RTX - Interactive (Path Tracing Mode). See image below. Is there any way to increase the quality or is that Rendering mode simply not meant to be used in VR?

I tried with the following set-ups. Non of which would achieve a rendering quality near to what you demonstrate online.

Thanks. Matthias

Goggles (Tethered)
Quest 2 & Quest 2 Pro, HTC Vive Pro & HTC Vive Pro 2

pc 1
Processor 11th Gen Intel(R) Core™ i9-11900KF @ 3.50GHz 3.50 GHz
Installed RAM 64.0 GB (63.8 GB usable)
NVIDIA GeForce RTX 3080 Ti 12GB

pc 2
Processor Intel(R) Xeon(R) CPU E3-1505M v5 @ 2.80GHz 2.81 GHz
Installed RAM 16.0 GB (15.9 GB usable)
NVIDIA GeForce RTX 3070 Eagle OC 8GB

pc 3
Processor Intel(R) Xeon(R) Gold 6248R CPU @ 3.00GHz 3.00 GHz (2 processors)
Installed RAM 512 GB (511 GB usable)
NVIDIA Quadro RTX 8000 48GB (2 graphic cards)

pc 4
Processor Intel(R) Xeon(R) Gold 6248R CPU @ 3.00GHz 3.00 GHz (2 processors)
Installed RAM 512 GB (511 GB usable)
NVIDIA Quadro RTX 6000 24 GB (4 graphic cards)

Hello @helmreich! I’ve shared your post with the dev team for further assistance.

In the meantime, take a look at our documentation if you haven’t already. I may have some helpful information related to your questions. Omniverse Create XR — Omniverse Create XR documentation

(Just to note: Omniverse VR User start point is a continuation of this forum post)

Hi,

Here are my settings. I hope this helps.

I’m very pleased (and impressed) with the rendering quality, especially in a simple environment like this.

With any of your setup described you shouldn’t be getting that result.

One thing that helps is to enable Foveation. That technique renders low quality outside of your focal view, enhancing the performance. Explore a little bit on that and you may have a better quality on VR.

My setup is:

Intel i9 - 9th Gen
64 GB RAM DDR4
RTX2070 Super 8GB
Liquid cooled
RiftS and Quest 2
LG C1 OLED 48in monitor

I bought both RTX4080 (still have to install) and Quest Pro (waiting for delivery).

More advanced settings


Hey @barizon,

Path Tracing mode isn’t currently supported in VR. We made it possible to preview this mode, but with effort (you need to manually set it). While we’ve been having fun with Path Tracing in VR, we don’t have a timeline for resolving all the issues with it yet, but we’re optimistic.