Omniverse xr with oculus quest2 question

I am designing app for an AAA client within automotive industry. Have modeled cars in CAD programs, and successfully prepared it and exported to 3ds max software linked to Omniverse. The model itself is very complex, with more than 10 millions of polygons, but havent any problem to export it and put materials and stuff in Omniverse. My goal is to prepare VR application to be used with Oculus quest 2. I read documentation for Create XR, downloaded Steam and installed steam VR. Installed Omniverse create XR and successfully open model in it. In viewport it looks just fine, but when I press "open VR", it crashes after 10 sec with error saying that I have to check if SteamVR is installed correctly. I checked it, and it is fine. Tried to open an empty scene in VR, and it crashes also in 10 I guess it is not due of heavy load scene. Also...I cannot pair my Oculus to cannot recognize it, and just showing Please plug in your VR headset. I tried everything, but it just doesnt work. Read documentation. It said that minimum requirement is RTX 3090. I have RTX3080, so maybe that is a problem (other requirements meet my specs…64Gb ram, i9 12th gen).
So, please, can you describe me, step by step how to solve my problem and play my file (or app) in oculus quest 2.

Thanks in advance

I assume you have the Occulus app running and your quest 2 is connected successfully in the app.

I found out that my USB-c cable was the problem. I even had it to work for few seconds, but the oculus app was saying it is USB 2 (not USB 3)…Didn`t know that my cable was only 2.0, and that I need 3.0 cable (not a plug itself)…so I bought new USB-c to USB-c 20Gb type of cable, and boom…running smooth as supposed :)