On Kubernetes, `drop-frame-interval` Interval is not working for nvurisrcbin

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) GPU - T4
• DeepStream Version 6.1
• JetPack Version (valid for Jetson only)
• TensorRT Version - 8.2.5-1+cuda11.4
• NVIDIA GPU Driver Version (valid for GPU only) 525.105.17
• Issue Type( questions, new requirements, bugs) Bug
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

"I’m using the NVURISRCBIN as the source bin for a multi-stream setup. I have deployed the container on the Kubernetes POD. I have set the value for drop_frame_interval to 2, but it is not reducing the FPS to half. However, on the same configuration VM, it is able to reduce the FPS and is working fine.

The only difference in the code is nvbuf-memory-type. For the Kubernetes POD, I’m using the value 0, and for the internal VM, I’m using 3."

Here is inspect output for the nvstreammux

Which FPS are you referring to? The FPS from performance or somewhere else?

@yingliu ,

On the VM, despite the source stream running at 10 FPS, I can process it at 5 FPS output by setting the drop frame interval value to 2. However, the same configuration on the POD doesn’t yield the expected result; it continues processing at the source FPS, ignoring the drop frame interval set to 2.

There is no update from you for a period, assuming this is not an issue any more. Hence we are closing this topic. If need further support, please open a new one. Thanks.
could you test the latest DeepStream6.4? if DS6.4 still can’t work, which sample are you testing? what is the whole media pipeline? how did you test fps?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.