On what laptops is CUDA 5.0 known to work with Ubuntu 11.10?

I recently purchased an HP dv7t laptop, but was unable to install the nvidia drivers with Ubuntu 11.10 64 bit. The nouveau driver works just fine. I’d like to use CUDA 5.0 with Ubuntu on a laptop and am willing to purchase whatever laptop is necessary. If you have CUDA 5.0 working under Ubuntu 11.10 on a laptop, please let me know which laptop and model you are using.

Hello,

I have acer 4830gt. The problem with the laptops is that they have optimus. If ou want to run cuda programs you need to install the bumblebee (https://wiki.ubuntu.com/Bumblebee) (in the process you also install the nvidia drivers x-swat). After installation you set bumblebee to use the the nvidia driver. Now you can install cuda. In general cuda toolkits will work with many versions of ubuntu. The 5.0 version works on my laptop whichhas 12.04.

Compile programs normally with nvcc and then run with optirun ./cudaprogram

Hello Pasoleatis,

Thank you for your reply.

Is my understanding correct that at time the optirun is invoked, that the nvidia driver is already loaded. Specifically, lsmod | grep nvidia shows ‘nvidia’.

–Graham

That’s correct, but if I remember correctly, the driver module gets loaded before optirun is even run.

On that note, I used to have a 4830TG and you could even do CUDA stuff without bumblebee, you just couldn’t load the drivers for X to do hardware acceleration… just had to a custom install of the NVIDIA drivers and modprobe the driver before you ran the CUDA code… it was flaaky sometimes, but it worked.

After a while I became aware of bumblebee and that indeed is able to do both CUDA and X acceleration via the optirun construct.

If your laptop is optimus, I recommend to install bumblebee anyway. It disables the nvidia card when not using it, which results in less noise and longer battery.Without bumblebee, doing nothing my battery was holding less than 4 hours, while with bumblebee more than 6 hours.

Hello,

An update. I have CUDA 5.0 running on my HP dv7 which includes a GeForce GT 650M chip. This hardware does support optimus and I am now using bumblebee. The hard part of the installation was that I’ve been using CUDA on desktops and didn’t know about optimus and bumblebee. Further, I didn’t know how bumblebee worked, specifically I was initially trying to configure xorg.conf to load the nvidia driver (as done on desktops). This produced a black screen on startup. The correct action is to leave the default X configuration alone (ie use the default X configuration that comes with the Ubuntu 11.10 install). At the time that the machine boots up and X is started, the nvidia driver is not loaded, specifically lsmod | grep nvidia shows nothing. However after bumblebee is installed and the system is rebooted, there should be a kernel module called ‘bbswitch’ and the ‘bumblebeed’ daemon should be running, see ps uaxww | grep bumblebeed. Then test with glxpheres (which doesn’t use the nvidia graphics card) and optirun glxspheres (which does use the nvidia graphics card). The glxsphere executable will announce which graphics engine is being used, which for the optirun case is ‘GeForce GT 650M’