One out of three monitors won't wake up after sleeping (KDE)

I’m running 3x 1080p@240hz monitors all with DP using a 2070 super. When I come back to my computer after a long period and need to wake it up, (sometimes) only two of the monitors wake back up. It seems random, but either my left monitor or my middle monitor stays off. I have yet to have issues with the right monitor. Meaning intermittent issues with DP-2 and DP-4, but not DP-0.

Opening up nvidia-settings and changing the refresh rate on the bad monitor, applying, and changing it back remedies the issue. It is a real pain in the butt to do every time.

Edit: Sometimes I need to switch refresh rates a couple of times for it to fix itself.

What do I need to start debugging this issue?

OS: Kubuntu 20.04
Kernel: 5.13.0-30-generic
DE: KDE Plasma 5.18.8
NVIDIA driver: 510.47.03

I forgot to add this:
nvidia-bug-report.log.gz (299.5 KB)

I don’t know if it is related, but I am also having an issue with the same monitors where they will go to sleep for a second once per startup. I cannot reproduce this issue consistently either.

Not sure if this is relevant, but I’ve also found a discrepancy between the names of the ports being used. I’m assuming one is X server and the other is a raw port name.

[ 49413.312] (--) NVIDIA(0):     DFP-0 (boot)
[ 49413.312] (--) NVIDIA(0):     DFP-1
[ 49413.312] (--) NVIDIA(0):     DFP-2
[ 49413.312] (--) NVIDIA(0):     DFP-3 (boot)
[ 49413.312] (--) NVIDIA(0):     DFP-4
[ 49413.312] (--) NVIDIA(0):     DFP-5 (boot)
[ 49413.312] (--) NVIDIA(0):     DFP-6
[ 49413.312] (--) NVIDIA(0):     DFP-7

Where X seems to be using DP-0, DP-2, and DP-4:

DP-2:1920x1080_240+1920+0,DP-0:1920x1080_240+3840+0,DP-4:1920x1080_240+0+0

It looks like DPMS is enabled. Could this be causing the issue? Would my monitors be incapable of sleeping if I turned this off?

Here is my xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 470.57.01

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUS VG259QM"
    HorizSync       255.0 - 255.0
    VertRefresh     48.0 - 240.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVIDIA GeForce RTX 2070 SUPER"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-3"
    Option         "metamodes" "DP-2: 1920x1080_240 +1920+0, DP-0: 1920x1080_240 +3840+0, DP-4: 1920x1080_240 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Disabling DPMS did not fix the issue.

Please check if the HardDPMS option helps.
https://download.nvidia.com/XFree86/Linux-x86_64/460.67/README/xconfigoptions.html

This is kind of a sub problem I have been having that seems to be related to another more annoying problem I have been having, which I have outlined here:

I think the monitor staying asleep while waking up might be locked in the same state as the one falls asleep while I’m using the desktop. So solving the problem from my other thread might fix this issue.