Only modular export works?

Hi!
I bought this nice asset:

How ever, exporting it to Omniverse was not so easy. I got those red materials on some assets:

I tried to export with different settings in Unreal export to USD:
Default

  • USD preview surfaces
  • no MDL option ( heheh gotta try! )
  • Core_Library

Finally the only option to bring in all the materials was to use the “Modular export” option :)
Exporting this way was really slow, but it worked.

Why is this so? How can I find out what was the reason for this issue?

export errors default:

export errors Core Library:

export errors Modular export:

Here is overview-meshes exported with "Modular export” option:

But when I export the actual environment itself, the main map, then I get those missing materials again:

So I have to manually bring in the books:

Or I can just use the “browse” function and replace each book group manually this way, a lot faster :)

Hi Pekka, could you please paste the log of Create here? I wanted to check what’s the detail of the error of the red materials, because there’s no error message during exporting

Thanks JulianCao!

Here is the full content of this folder, zipped for you.
omni.kit.internal.zip (8.2 MB)

You missed a new mdl core function object_world_position when loading.
So I wanted to know that did you use “Including Dependencies” when exporting mdl?
Because the core mdl library could be different between UE4 connect and Create, the safe way is always including dependencies when exporting UE4 assets.

Shared or Modular exporting isn’t the cause.

Tried them both, as a first option.
Let me do a video for you…

First here is default export:

And errors after export:

Then I exported with that core option:

And the errors after export:

so both comes out with the books red :/

OK @pekka.varis - I think the root of the issue here is that something is wrong with specifying the template locations. If you leave the Destination UE4 Template Path empty then the object_world_position MDL function is found properly and the materials should work.

image

The behavior of this optional path works like this:

  • If you leave it blank the default location for the MDL templates will be in the ./Materials folder where your stage is exported
    image
  • If you put something there then the templates are SUPPOSED to be copied to the path you provide and referenced properly by your materials in that location. This appears to have an issue.
    image

wow! I continue tomorrow :) Thanks!!
I have just made a fresh win 10 install and I installed the Omniverse & Unreal all to default locations at C:

Pekka

I leaved that empty, but I exported it to a new folder:

Export errors:

And all worked great! Thanks!!

It also loaded in super fast, for a first time opening… :)