OpenCL application fails with nvidia 410.73 driver on linux kernel 4.18.16


I’m trying to use nvidia driver 410.73 on fedora 29 kernel 4.18.16. X Window works fine, but OpenCL application has a problem. It says

Error: GPU steps do not match CPU steps.  Workunit processing aborted.

and aborts. Other users using kernel 4.15.x on ubuntu 18.04 seem to succeed. So I am using nvidia 396.54 driver. The application is used at, but I am suspecting this applies to any OpenCL applications.

Does anyone help me? I don’t know how to get further error messages, so am at a loss what to do.

Thanks in advance!!


Same driver and kernel version on Fedora29.
Sidefx Houdini crashes when I turn on opencl but before it dies I get this error:

X server found. dri2 connection failed!
DRM_IOCTL_I915_GEM_APERTURE failed: Invalid argument
Assuming 131072kB available aperture size.
May lead to reduced performance or incorrect rendering.
get chip id failed: -1 [22]
param: 4, val: 0

Thanks in advance.

Sorry in my case removing beignet solved my problem. Seems like a conflict.

Thanks for reply.

I tried to remove beignet (actually I had had one installed), but this phenomenon still persists. Without beignet, OpenCL application still aborts…

best regards,