OpenCL error: Error -1001 in clGetPlatformIDs Call !

Hello,

i want to try out OpenCL so I installed the cudatoolkit_3.0_beta1 and gpucomputingsdk_3.0_beta1. My OS is Gentoo Linux 64Bit with a 2.6.32 Kernel. My NVIDIA Driver is: 195.36.03 the hardware used is a NVIDIA Geforce 8600M GT.

When I try the OpenCL examples I get the following error:

sdk/OpenCL/bin/linux/release/oclDeviceQuery

oclDeviceQuery.exe Starting...

OpenCL SW Info:

Error -1001 in clGetPlatformIDs Call !!!

Segmentation fault

This error occurs on every single OpenCL example. The CUDA examples run just fine so i think it isn’t a hardware problem.

Regards

Melekh

This is a driver error, the Gentoo 195.36.03 is not compatible with the 3.0_beta1 SDK.

You need to install the cudadriver_3.0-beta1_linux_64_195.17-beta.run that’s on the NVIDIA developer website, although this is easier said than done.

I had to create a custom ebuild in a Portage overlay to fix this.

Tim

It took me the better part of a day to get this working…hopefully my experience will help someone. I can confirm that the NVIDIA GPU Computing SDK 3.0 Beta 1 only works under Gentoo with the NVIDIA drivers version 195.17 available at http://forums.nvidia.com/index.php?showtopic=149959.

To get these installed in Gentoo is a little tricky, and there is no publicly available ebuild to accomplish this…until now. This ebuild should work with both x86 and amd64 architectures. I have not tested this ebuild and do not warrant it to be suitable or fit for any use whatsoever. I’m sure it has bugs and errors. But at least it worked for me.

To get the NVIDIA GPU Computing SDK 3.0 Beta 1 working under Gentoo, you need to follow (roughly) the following steps. I apologize if I left anything out of the process:

1. First, we need to create a local Portage overlay
mkdir /usr/local/portage/local
mkdir /usr/local/portage/local/profiles
echo “local_overlay” > /usr/local/portage/local/profiles/repo_name
mkdir /usr/local/portage/local/x11-drivers
mkdir /usr/local/portage/local/x11-drivers/nvidia-drivers

2. Now we need to enable this overlay in Portage. Add the following line to the end of /etc/make.conf
PORTDIR_OVERLAY="${PORTDIR_OVERLAY} /usr/local/portage/local/"

3. Next we need to install the new ebuild, along with some required patches
Download the nvidia drivers ebuild from http://www.mediafire.com/file/2ogjziyxwkz/…-195.17.tar.bz2

4. Extract the ebuild to our local Portage overlay. Assuming the file from the previous step was saved at /home/user/nvidia-drivers-195.17.tar.bz2, do the following
cd /usr/local/portage/local/x11-drivers/nvidia-drivers
tar -xvjf /home/user/nvidia-drivers-195.17.tar.bz2

5.a. Enable the ebuild in Portage
echo “=x11-drivers/nvidia-drivers-195.17” >> /etc/portage/package.unmask

5.b. Enable the ebuild in Portage
Only for x86:
echo “=x11-drivers/nvidia-drivers-195.17 ~x86” >> /etc/portage/package.keywords
Only for amd64:
echo “=x11-drivers/nvidia-drivers-195.17 ~amd64” >> /etc/portage/package.keywords

6. Install the ebuild
emerge =x11-drivers/nvidia-drivers-195.17

Thank you very much tried it today with the specified driver and now it works.

Regards
Melekh

have the same problem in opensuse 11.1 64bit, nvidia driver version 256.53

http://forums.nvidia.com/index.php?showtop…lgetplatformids

not solved yet

have the same problem in opensuse 11.1 64bit, nvidia driver version 256.53

http://forums.nvidia.com/index.php?showtop…lgetplatformids

not solved yet