OpenCV 2.4.9 and CUDA 6.0: cuda.h: No such file or directory

When trying to compile OpenCV 2.4.9 with CUDA 6.0 support, I get the following error:
fatal error: cuda.h: No such file or directory

CUDA 6.0 seems to be running fine, nvcc works and the samples too.

There is still an instance of CUDA5.5 on my computer. With that version I did not get nvcc to run, however it worked with OpenCV. Upon closer inspection it seems this instance does have cuda.h, located in /usr/local/cuda-5.5/include.

cuda.h is missing in /usr/local/cuda-6.0/include though. I tried hacking around it by simply copying cuda.h from /usr/local/cuda-5.5/include to /usr/local/cuda-6.0/include. This worked, however the next error I got was:

cufft.h: No such file or directory

This file too I copied from /usr/local/cuda-5.5/include to /usr/local/cuda-6.0/include. This also solved the error, but I do not think this is the way to go.

So I am left wondering what’s wrong. I take it /usr/local/cuda-6.0/include is supposed to contain those header files right? If so, does that mean something went wrong with the installation of CUDA?

Any help is much appreciated!

For some reason the forum says that the last comment was 45 years ago, so by replying I hope I’ll reset the timer…