OpenCV 3.2 with extra modules on TX2

Has anyone successfully installed OpenCV 3.2.0 with extra modules (opencv_contrib) on TX2? I cannot get it to build sfm and tracking modules.
outtake from cmake:

– Glog: YES

– Module opencv_sfm disabled because the following dependencies are not found: Glog/Gflags
– Module opencv_tracking disabled because opencv_dnn dependency can’t be resolved!

I installed glog and gflags with:
sudo apt-get install libgflags-dev libgoogle-glog-dev

I will add full cmake output in attachment.

Best regards,
Arvids
cmake_ocv3_2.txt (22.4 KB)

HI ArvidsP,

I am also building this and hit same error. Does this installation only fail on tegra? If it is a problem specific to opencv, please also file a question in opencv forum.

Thanks.

Hi Wayne,

Installation does not fail, but it does not build these 2 modules. This happens only on TX2. Both JetPack3.0 and 3.1. Ok, i will file a question there.

Arvids

So the missing modules are installed successfully on x86_64 machine?

Yes, as well as TX1 with JetPack 2.x and Raspbian.

Hi
I manually modified the files in module TRACK to exclude goturnTracker which using “opencv-dnn”, then I can build track-module without “GOTURN tracking algorathm”.

Hi hc-tx2,

Thank you for your answer! Could you share a bit more? Which files should i modify and what should i look for?

I met exactly the same problem, the extra module(tracking module) cann’t be install on tx2. Have you solved the problem?

I solved it by using an older version of OpenCV 3.0, if you can call that a solution.

Hi,

Unfortunately I got the same error (Jetpack 3.1 + opencv 3.2).

Any developments for solving this issue? Could be cool to be able to use tracking modules…

sojohans

Hi!

You can try
git clone https://github.com/opencv/opencv.git
cd opencv && git checkout 9313978f618dbe39ad737ccd8bffa23b52d59aaa

git clone https://github.com/opencv/opencv_contrib.git
cd opencv_contrib && git checkout ffdec47924cc680518f7d0c56064fff393b6e996

If that does not work i can try to help some more, because i did solve the problem, but i had a bit different software. You could get a protobuf error.