OpenCV, CUDA, Python with Jetson Nano

Hi,

i have installed the opencv using the automatic script, but i keep getting that the cv2 module is not found. i have found that opencv is installed inside /usr/local… and python is installed inside /usr/bin. could this be the reason?

thanks

Hello,

i have just compiled opencv 4.1.0 using the script.

In your opencv installation directory, you need to do something more.

For example, you have created opencv-4.1.0 directory to compile opencv.

Go there : opencv-4.1.0/release/python_loader

Then :

$ sudo python3 setup.py install

It should solve your problem.

Thanks a lot @easybob! That’s just what was needed to finish the install!

Thanks @easybob!
Everything is now working !

Hi all,

I ran the script linked below successfully.
https://github.com/AastaNV/JEP/blob/master/script/install_opencv4.0.0_Nano.sh

But once done there’s no cv2 that I can import:
$ python3
Python 3.6.8 (default, Aug 20 2019, 17:12:48)
[GCC 8.3.0] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

import cv2
Traceback (most recent call last):
File “”, line 1, in
ModuleNotFoundError: No module named ‘cv2’

Any suggestion to solve this?

Thanks!

Problem solved by running above commands. Thanks @easybob

Great !

Alain

Hello world!I just installed the suggested script provided by nvidia. I have some questions … First of all, which compiler should i use in order to compile opencv4 C++ with CUDA? Im asking because i wrote some demos and nvcc worked fine with OpenCV3 and CUDA(NPP).Furthermore i would appreciate if someone could give me an example of compilation.
(something like: g++ source.cpp opencv --cflags --libs --static opencv … )
Thanks in advance!

Hello,

you should take a look here :

https://devtalk.nvidia.com/default/topic/1056064/jetson-projects/electronically-assisted-astronomy-with-a-jetson-nano/post/5358642/#5358642

Alain

Your project seems quite interesting ,but the fact that you implemented it in pyhon doesn’t help me a lot because im interested in C++ and i didnt find any helpful documentation about the problem im dealing with.Do you have any more hands on examples to provide me with please?

ok, i have misunderstood your query.

Sorry for that.

Alain