Opencv tracking.hpp missing? (Solved)

I used Jetpack to install environments on Linux18.04 host and Xavier. It appears that Openvc3.3.1 is installed, but the opencv2/tracking.hpp header is missing. I see the same problem on both the host and the Xavier. I assume Jetpack installed Opencv4Tegra and I hope to use that, I don’t want to build from source because I want the optimizations.

Is the entire tracking feature absent? Is this because of the annoying SIFT and SURF thing?

Is there a workaround that doesn’t throw away the optimizations?

Hi,

Most optimization for Jetson is upstreaming.
It’s recommended to build it from source to get the latest feature:
https://github.com/AastaNV/JEP/blob/master/script/install_opencv3.4.0.sh

We include OpenCV package just for providing users some the basic vision operation.
You will need to build it if some required feature is not supported.

Thanks.

1 Like

These trackers may only be available from opencv_contrib.
You may clone the branch for your opencv release, and there will be a modules directory in this cloned source tree. You would pass this modules directory’s path as CMake option OPENCV_EXTRA_MODULES_PATH and these should be built as other extra modules.

Additional note: in opencv4, cuda libs will only be available from opencv_contrib, so it may be useful to get familiar with this.

Thanks. I’ve worked though this and have found a few surprises. AastaLLL, your script was helpful but some references are missing when run on 18.04. I’ve got things working, but a few run time hangups occur in special cases with ROS. When I get it all sorted out I’ll post notes.