OpenGL and ShadowPlay

How would I go about getting SahadowPlay to work with my OpenGL game engine? I’ve already hooked up the Geforce Experience Settings API; now I just need to figure out how to get the game listed and working with Shadowplay.

Thanks

Your engine is likely running on Integrated graphics rather than Nvidia graphics. I ran into this problem recently. I have not found any hard-code fixes for this, but you can force your engine to run on the GPU if you go to your Nvidia Control Panel -> Manage 3D settings, add your game, then set “OpenGL rendering GPU” to your GPU model. This obviously isn’t a shippable fix, but It will at least let you test out Shadowplay.

I do have an integrated gpu as well, but I’m definitely not using it (unless I’m debugging or performance testing it)

As far as a hard code fix, if you are using C++ you can add this piece of code to force use an Nvidia gpu.

extern “C” {
_declspec(dllexport) DWORD NvOptimusEnablement = 0x00000001;
}

Awesome thanks! I had been looking for this.