openmpi version

I have a 4-nodes small cluster and they are installed the openmpi 2.0. Now I would like to install the PGI community edition. During the installation, the system will ask me whether to install the openmpi 1.10.2 or not. Can I keep
using my latest openmpi 2.0, not a old PGI-built openmpi 1.10.2 ? If so, is there any setting I need to change to link the CUDA ? Thank you

Installation of your own version of OpenMPI should not be problem
with other versions of OpenMPI installed.

I assume you built OpenMPI 2.0 with the installed PGI compilers,
and therefore

export PATH=/path/to/openmpi/2.0/bin:$PATH

will successfully cause

mpif90, mpic++, mpicc to work using the PGI compilers.

export PATH=$PGI/linux86-64/2016/mpi/openmpi/bin:$PATH
will put the older PGI openmpi version in place, for any sanity checks.

dave