Optix 3.7.0 & GTX 580

I tried new Optix 3.7 version and I got this error (also in precompiled examples) with my card GTX 580:

Unknown error (Details: Function "_rtContextCompile" caught exception: Assertion failed: "instr->arguments[idx]->kind == ptxSymbolExpression", [1311487]

I tried also newest drivers (344.75) without success.

Which precompiled examples did you try?
32-bit or 64-bit?

You also see that in your own programs?
Which CUDA toolkit version are you using?

Could you please add some more details about your system?
OS version, OS bitness, application bitness.

Yes, I tried own project and when crashed, then I tried yours samples.
I compiled ptx files by CUDA 6.5 version, now I tried with CUDA 6.0 and same problem.

I am using Windows 7 64-bit and only 64-bit applications with Optix.
On other computer with GTX 690 or Titan card isn’t problem.

Ok, thanks, I’ve forwarded this issue to the OptiX team for investigation.

Hi, I have the same problem and my computer is 64-bit win7 and Quadro 6000 card with 340.84 driver.

Hi, I encounter the same problem, running samples & demos

Optix: 3.7.0 64-bit
OS : Windows 7 64-bit
CUDA : 5.0 & 6.0 installed on my comp
card : GTX 580
driver : 340.52

Same error here:
Optix: 3.7 beta
card: Quadro 3000M,
driver: 340.62,
OS: Windows 7 64-bit

Any changes for ETA?

Fixed in beta 2! Available for download now.

Thanks, it works now.