Optix Denoiser on Mavericks


I’m trying to run the pre-compiled Optix denoiser sample on Mavericks (10.9.5) using Optix SDK 5.0.1.
(GPU is GTX 775M)
I have copied both liboptix_denoiser.dylib and libucart.9.0.dylib in: optixDenoiser.app/Contents/MacOS
When I run the executable I get the following error:

OptiX Error: ‘Unknown error (Details: Function “RTresult _rtCommandListFinalize(RTcommandlist)” caught exception: Could not load denoiser library.)’

Edit: Other samples (eg pathTracer) run fine.

Has anyone faced the same issue?


Hi @efounariotakis,

Will you run your optixDenoiser sample using strace to see where it’s trying to load the denoiser library from? Check to make sure the directory you’ve placed your .dylibs appears in strace output, and check to make sure there aren’t any filename spelling differences and that optixDenoiser isn’t looking for a slightly different filename than the one you have.


Hi David,

The directories/filenames seem to be correct (I used dtruss).
As a test, I tried to explicitly load liboptix_denoiser.dylib and it failed. dlerror() returned:

dlopen(/Developer/OptiX/lib64/liboptix_denoiser.dylib, 2): Symbol not found: _OSAtomicDecrement32Barrier
Referenced from: /Developer/OptiX/lib64/libcudnn.7.dylib
Expected in: /usr/lib/libSystem.B.dylib
in /Developer/OptiX/lib64/libcudnn.7.dylib

I tried the same for libcudart.9.0.dylib (which is also a dependency for liboptix_denoiser.dylib), the above error appeared there as well.

I’d have to guess there’s a version mismatch. I Googled that error message and found another NVIDIA forum thread that seems relevant https://devtalk.nvidia.com/default/topic/939889/-solved-kind-of-cuda-8-on-mac-ld-symbol-s-not-found-for-architecture-x86_64/ Does the answer there make sense & help you? If that’s the same problem you have, it would seem to indicate that liboptix_denoiser, as well as libcudnn & libducart, were linked against something later than Mavericks, probably El Capitan.


Thanks for your follow-up. As I see it, the issue you linked and mine probably have the same origin. If this is the case, my understanding is that the denoiser component of the SDK can’t be used on OSX Mavericks, is this correct?

Yeah, I think that is the current sad state of things, that the denoiser was released post Mavericks and we’ve never had a build of it that works with the legacy OSX drivers that are still running on Mavericks. We still have hope that Apple will certify a current driver some day soon.