ORIN AGX PCIe ports not working on Production Modules l4t 35.2.1


I have just developed a new ORIN AGX configuration for a custom board, verified and tested everything on a ORIN AGX devkit module with SKU: 699-13701-0000-500 H.0 (read from eeprom).

My original ODM data setup from the config file was:

Running this on a production module (SKU: 699-13701-0004-500 G.0) would freeze when booting UEFI.

I was advised to try this odm config below (it worked on the devkit module as well):

This booted on the production module, however I no longer can detect PCIe devices on PCIe C5, and I think all of my PCIe ports may be down as the phy link is not going up in the dmesg.

The custom board has the following:
10G ports disabled
PCIe C0 x1

//PCIe C0
pcie@14180000 {
    status = "okay";
    num-lanes = <1>;
    phys = <&p2u_hsio_0>;
    phy-names = "p2u-0";

PCIe C5 x4
//PCIe C5
pcie@141a0000 {
status = “okay”;
num-lanes = <4>;
phys = <&p2u_nvhs_0>, <&p2u_nvhs_1>, <&p2u_nvhs_2>, <&p2u_nvhs_3>;
phy-names = “p2u-0”, “p2u-1”, “p2u-2”, “p2u-3”;

PCIe C7 x2
//PCIe C7
pcie@141e0000 {
status = “okay”;
num-lanes = <2>;
phys = <&p2u_gbe_0>, <&p2u_gbe_1>;
phy-names = “p2u-0”, “p2u-1”;

USB2-0,USB2-2, USB2-3 are enabled
USB3-1 and USB3-2 are enabled
I tried 35.1.0, but I am having the same issues.
Any idea why a devkit module works with the ODM configs described previous, but the production modules do not?

What ODM data string do you recommend for that kind of a configuration? I’ll continue testing on Monday, I am out of office right now. Please let me know anything I can try to diagnose the issue with these production modules.



You’ll probably want to move this to the AGX Orin forum. You’re posting in the older (and much different) Nano forum.


It seems your ODMDATA is wrong. Where did you get that advice?

Please refer to document.


You should use


Hi WayneWWW,

Thanks for the quick response. I got that advice from a Senior Engineer who had been working with Orin since the Early Access of Jetpack 5.0,

I tried the ODM data you provided, however I still cannot see PCIe devices off of C5. All of my other PCIe ports are working. It was working with the old odm data on the devkit module.
Do you have any other advice on what to try?



Then I don’t think your issue is related to ODMDATA.

What is the jetpack version in use here?

Jetpack 5.1

Could you put both of your Orin devkit module and Orin production module to devkit and use jetpack to test if the C5 can work fine or not?

The point here is C5 are both in use for config#1 and #2. And devkit by default is using config #1.

Please use same test device and share what is the result on devkit.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.