Orin AGX: USB camera not detected in jetson-inference container

Using a webcam with new Orin system. Upon plugging in camera shows up in /dev/video

orin@orin1:~$ ls /dev/vid*
/dev/video0 /dev/video1

orin@orin1:~$ lsusb

Bus 001 Device 009: ID 0c45:6366 Microdia USB 2.0 Camera

However, within the jetson-inference containter (the Hello World AI example at https://github.com/dusty-nv/jetson-inference/blob/master/docs/aux-docker.md) it does not show up:

root@orin1:/jetson-inference/build/aarch64/bin# video-viewer v4l2:///dev/video0
[gstreamer] initialized gstreamer, version 1.16.2.0
[gstreamer] gstCamera – attempting to create device v4l2:///dev/video0
[gstreamer] gstCamera – didn’t discover any v4l2 devices
[gstreamer] gstCamera – device discovery and auto-negotiation failed
[gstreamer] gstCamera – failed to create device v4l2:///dev/video0
video-viewer: failed to create input stream

root@orin1:/jetson-inference/build/aarch64/bin# ls /dev/vid*
ls: cannot access ‘/dev/vid*’: No such file or directory

Hi @randy.goebbert ! I moved this post over to the Orin part of the forum - you’d posted it in the DGX area, and not sure it’d get the best eyes on it over there.

ScottE

Hi @randy.goebbert, can you try running video-viewer with /dev/video1 instead?

same results within the container… neither /dev/video0 or /dev/video1 works:

oot@orin1:/jetson-inference/build/aarch64/bin# video-viewer v4l2:///dev/video1
[gstreamer] initialized gstreamer, version 1.16.2.0
[gstreamer] gstCamera – attempting to create device v4l2:///dev/video1
[gstreamer] gstCamera – didn’t discover any v4l2 devices
[gstreamer] gstCamera – device discovery and auto-negotiation failed
[gstreamer] gstCamera – failed to create device v4l2:///dev/video1
video-viewer: failed to create input stream

thank you

this started working when I restarted the container with the camera plugged in… not sure why, but /dev/video0 is now showing up… OK to close this

OK, glad you got it working! Yes, you must start the container after the camera gets plugged in.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.