Orin by Jetpack 5.0.2 HDMI 17-inch display cannot be displayed

Orin cannot be displayed on the 17-inch display when it is turned on, and the screen is black; Its display resolution is 1440x900
Xorg.0.log (39.0 KB)

What is the result of “xrandr”?

Did you know that default BSP does not support HDMI and you need to manually modify the device tree?

hi WayneWWW
新的 Xorg log 包;包括了同一个 Xorg 配置 下的两份 log,HDMI 一个是能显示的,一个是不能显示的。
Xorg 配置 如下:
Xorg.0.log.tar.bz2 (23.1 KB)

$ cat /etc/X11/xorg.conf

Copyright (c) 2011-2013 NVIDIA CORPORATION. All Rights Reserved.

This is the minimal configuration necessary to use the Tegra driver.

Please refer to the xorg.conf man page for more configuration

options provided by the X server, including display-related options

provided by RandR 1.2 and higher.

Disable extensions not useful on Tegra.

Section “Module”
Disable “dri”
SubSection “extmod”
Option “omit xfree86-dga”

Section “Device”
Identifier “Tegra0”
Driver “nvidia”

Allow X server to be started even if no display devices are connected.

Option “AllowEmptyInitialConfiguration” “true”

Option      "ModeDebug"



其實我想說的是, 麻煩你把整個問題敘述的清楚一點. 比方說我們default BSP根本就沒有支援HDMI.
如果你是custom board的話麻煩也說明一下你是否是在用custom board.

原本的敘述丟出一個HDMI沒辦法display然後也沒有說明其他的部份. 說實話我們也不太清楚你到底想問什麼.

hi WayneWWW!
display@13800000 {
status = “okay”;


    nvdisplay: display@13800000 {
            compatible = "nvidia,tegra234-display";
            power-domains = <&bpmp TEGRA234_POWER_DOMAIN_DISP>;
            nvidia,num-dpaux-instance = <1>;
            reg-names = "nvdisplay", "dpaux0", "hdacodec", "mipical";
            reg = <0x0 0x13800000 0x0 0xEFFFF    /* nvdisplay */
                   0x0 0x155C0000 0x0 0xFFFF     /* dpaux0 */
                   0x0 0x0242c000 0x0 0x1000     /* hdacodec */
                   0x0 0x03990000 0x0 0x10000>;  /* mipical */
            interrupt-names = "nvdisplay", "dpaux0", "hdacodec";
            interrupts = <0 416 4
                          0 419 4
                          0  61 4>;
            nvidia,bpmp = <&bpmp>;



I am not sure why you posted a dts file that seems not helping…
Please check below posts for the necessary change required…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.