Orin devepkit hangs and no image on display monitor

Hi:
We have a orin develop kit today,and i flash the kit by sdkmanager,show success!
but when power the kit ,no image no display monitor;
here is the uart log;
show last line is:
Please wait for auto system configuration setup to complete…
orin-uart-log.txt (83.5 KB)

Please run ./tools/l4t_create_default_user.sh before flashing and flash it again.

After you can operate the console, please rmmod nvidia.ko, set dmesg log level higher.

dmesg -n 7

And then insmod the nvidia.ko module again with below command.

sudo insmod /lib/modules/$(uname -r)/extra/nvidia.ko NVreg_RmMsg=":"

Hi WayneWWW:
After run ./tools/l4t_create_default_user.sh and flash.
can operate the console,i try to romod nvida.ko,but in use.
图片

and the monitor still shows nothing.

  1. The monitor will not work. What we are doing is just dumping log. I didn’t provide any magic trick to make your monitor work.

  2. Please kill gdm3 service so that nvidia_modeset.ko could be rmmod.

I’m running into the same issue. I’ve attached my output from running the following:

sudo service gdm3 stop
sudo rmmod nvidia_modeset.ko
sudo rmmod nvidia.ko
sudo dmesg -n 7
sudo insmod /lib/modules/$(uname -r)/extra/opensrc-disp/nvidia.ko NVreg_RmMsg=":"
dmesg > dmesg.txt

Note how my insmod command is slightly different. The only thing in the extra directory hwas the opensrc-disp directory.
dmesg.txt (84.7 KB)

Hi,

Could you also hotplug the monitor cable under such state and dump dmesg again? Will you see any new log under such case?

I rebooted the Orin with the monitor unplugged, ran those commands, plugged in the monitor, then unplugged the monitor all while keeping an eye on dmesg.
I’ve attached the output:
dmesg-monitor-in-out.txt (76.6 KB)

After I ran all those commands, but before I plugged in the monitor, the last line was at 104.784132.
Plugging in the monitor caused the line at 116.231236.
Unplugging the monitor caused the line at 169.257698.

(My apologies for using a different username, I’m having trouble logging into my other account)

Could you also enable gdm service and check the dmesg after current status?

With the monitor still unplugged, I restarted gdm3 and got this output from dmesg:
after-gdm3.txt (134.3 KB)

Then I plugged in the monitor:
after-gdm3-then-monitor-in.txt (134.1 KB)

Is your monitor a pure DP monitor? or you are using some adapters here?

I’m using a DP-to-HDMI adapter (It works with other devices).

Hi,

Is that adapter an passive one or active one?

Do you also load nvidia-modeset.ko back or not? If not, please load it too.

And after load it back, restart gdm and share the monitor info.

export DISPLAY=:0
xrandr

Hi rob_sv2:

I think you need the DP-DP cable.

I used DP-HDMI first and find the monitor no display then after changed DP-DP cable the monitor is ok!

1 Like

For the adapter, I’m assuming it’s active as it has a small box component.

I didn’t load nvidia-modeset.ko back, so I rebooted and ran the following commands:

sudo service gdm3 stop
sudo rmmod nvidia_modeset.ko
sudo rmmod nvidia.ko
sudo dmesg -n 7
dmesg > dmesg1.txt
sudo insmod /lib/modules/$(uname -r)/extra/opensrc-disp/nvidia.ko NVreg_RmMsg=":"
dmesg > dmesg2.txt
sudo insmod /lib/modules/$(uname -r)/extra/opensrc-disp/nvidia-modeset.ko NVreg_RmMsg=":"
dmesg > dmesg3.txt
sudo service gdm3 start
dmesg > dmesg4.txt
# Note: plugged in monitor
dmesg > dmesg5.txt
export DISPLAY=:0
xrandr

dmesg1.txt (76.4 KB)
dmesg2.txt (76.7 KB)
dmesg3.txt (79.4 KB)
dmesg4.txt (94.5 KB)
dmesg5.txt (134.0 KB)

The output of xrandr was:

No protocol specified
Can't open display :0

Are you sure gdm3 is on? Could you check /var/log/Xorg.0.log and see if it has any error indicating gdm3 fails to launch?

No issues, as far as I can tell.

$ service gdm3 status
● gdm.service - GNOME Display Manager
     Loaded: loaded (/lib/systemd/system/gdm.service; static; vendor preset: enabled)
     Active: active (running) since Fri 2022-04-22 19:39:47 AEST; 3h 1min ago
    Process: 2681 ExecStartPre=/usr/share/gdm/generate-config (code=exited, status=0/SUCCESS)
    Process: 2683 ExecStartPre=/usr/lib/gdm3/gdm-wait-for-drm (code=exited, status=0/SUCCESS)
   Main PID: 2684 (gdm3)
      Tasks: 3 (limit: 36425)
     Memory: 2.3M
     CGroup: /system.slice/gdm.service
             └─2684 /usr/sbin/gdm3

Apr 22 19:39:36 orin1 systemd[1]: Starting GNOME Display Manager...
Apr 22 19:39:47 orin1 systemd[1]: Started GNOME Display Manager.
Apr 22 19:39:47 orin1 gdm-launch-environment][2688]: pam_unix(gdm-launch-environment:session): session opened for user gdm by (uid=0)

Xorg.0.log (13.9 KB)

[ 337.977] (–) NVIDIA(0): VideoBIOS:
[ 337.977] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 337.977] (–) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[ 337.977] (–) NVIDIA(GPU-0): DFP-0: 2380.0 MHz maximum pixel clock
[ 337.977] (–) NVIDIA(GPU-0):
[ 338.059] (–) NVIDIA(GPU-0): DFP-1: disconnected
[ 338.059] (–) NVIDIA(GPU-0): DFP-1: Internal TMDS
[ 338.059] (–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[ 338.059] (–) NVIDIA(GPU-0):
[ 338.059] (==) NVIDIA(0):
[ 338.059] (==) NVIDIA(0): No modes were requested; the default mode “nvidia-auto-select”
[ 338.059] (==) NVIDIA(0): will be used as the requested mode.
[ 338.059] (==) NVIDIA(0):
[ 338.059] (–) NVIDIA(0): No enabled display devices found; starting anyway because
[ 338.059] (–) NVIDIA(0): AllowEmptyInitialConfiguration is enabled
[ 338.341] (II) NVIDIA(0): Validated MetaModes:
[ 338.341] (II) NVIDIA(0): “NULL”
[ 338.341] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480

Looks like not able to detect. Please change the adapter or directly use native DP.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.