Orin not flashing correctly

I’m trying to flash a jetson orin and am running into a USB timeout issue. I was able to find an old thread that said that the older orins needed to be RMAd to fix the firmware issue with the USBc to host connection. I was told I needed to submit a post here for the RMA.

Which thread are you referring to?

The conclusion is not for your board but only for that user… there is no firmware to change here…

If you have problem in flashing, dump the serial console log from micro usb port on the board first.

If there is no log coming out, then please try other host machine to flash.

SDKM_logs_JetPack_5.0.2_(rev._2)_Linux_for_Jetson_AGX_Orin_modules_2023-06-21_09-31-04.zip (180.8 KB)

I need you to dump the device log too…

Is that the minicom log? how do I save that off the terminal

Minicom isn’t giving us an output when we run the flash. Where can I find the device logs.

If you are sure your setup is correct, then try other machine PC to flash your board.

I think the issue is with minicom’s connection not the host pc. I do not have any other ubuntu machines


Just to clarify. Minicom connection is just for dumping log.
Dumping log has no direct relation with flash.

For example, I don’t need to dump log but I can still flash my board. Minicom result does not matter to me on my side.

You could also try to disable usb auto suspend on your host and see if that works.

SDKM_logs_JetPack_5.0.2_(rev._2)_Linux_for_Jetson_AGX_Orin_modules_2023-06-21_10-16-10.zip (199.8 KB)
That was also unsuccessful. If the minicom isn’t the device logs, Im not sure why I need minicom nor where I can get the device log.

Minicom is the device side log. That is correct.

The point here is if minicom shows any error log when flash failure happened, then I need that log to check.

But if minicom just gives nothing, it means some early communication with your host and jetson already failed so no software log got printed. For such case, you need to try other host machines.

If you are a total newbie to dump device side log, then maybe you can try to use minicom to dump boot up log instead of flash log. Orin should be able to dump some serial log from micro usb port during boot (even with the case that the boot fails in the end).

Hope this clarify why we need minicom log.

Also, please try latest jetpack version. jp5.0.2 is already old one.

I got a boot up log in minicom the first time but never again. I don’t even get a message when I try to flash.

I got a boot up log in minicom the first time but never again

Did you do anything after that? As I said, the micro usb port (not type C port) on Orin can dump log when it powers on in any condition.

I tried to flash it after that. I am using the microusb port.

Please be aware that I am asking you to dump the “boot up” log for now. Not flash log.

Since your flash didn’t succeed even once, the data on jetson orin should still be there.
Those logs are sufficient to validate whether your minicom is able to get log or not.

If you don’t get the logic here…let me clarify it

  1. Use boot up log to validate if your minicom really can get any log
    ->if it cannot then check the baud rate and if the board is really powered on. If the board is in recovery mode, then it won’t have log.

  2. If you can see some logs printed from minicom, then we are sure minicom can dump log. Which means your previous comment “flash does not give out any log” is true.
    For that case, I can only ask you to try other type C cables or host PC.

ok. I was able to get a log on the boot up. Its stuck on the login prompt. I’ve tried a different USB C cable. I can upgrade to a newer jetpack, do I do that from SDK Manager.

We tried a different cable and such. We’re having an issue regarding the jetson failing to boot correctly now. How can I expediate this RMA?