Orin nx 16G How do I back up a production image?

I have burned OrinNX on my computer and it works fine, but I want to move the environment to another computer. What do I do? Is there a proper command or method for me to hit the target.
And how do I back up my board image when my board has successfully set up some environment?

Hi, not sure what your first question is about, you mean you want to move the Ubuntu system on the host PC to another computer?
For the second question, you should refer to To clone a Jetson device and flash for how to back up and restore the system on Jetson.

Hello, this command doesn’t seem to work. Try harder. I’m Orin

NX 16G. I have uploaded the log. I don’t have EMMC, only NVME.

This is my order.
 sudo ./flash.sh -r -k APP -G backup.img p3509-a02+p3767-0000 nvme0n1p1

LOG.txt (61.1 KB)

In addition, when I Ctrl + C to end the backup, I have the backup in the image below.

Hi, sorry for misleading you.

The previous method using flash.sh only supports eMMC/SD, which is not present on Orin NX.
Please use the new tool as specified here:
To back up and restore a Jetson device

Also you need to replace all mmcblk0 with nvme0n1 in nvbackup_partitions.sh and nvrestore_partitions.sh under


for the script to work with NVMe drives.

Check this thread for more detail.

Hi, looks like you are using JetPack 4.6.2, which does not support Orin NX, so the config file needed for flashing devices is missing.
Not sure how you get the older version of JetPack to work on the device, but please use 5.1 (L4T 35.2.1), or 5.1.1 (L4T 35.3.1), which officially support Orin NX.

Oh, I noticed my mistake and deleted the reply immediately. How did you see it? 😁

Good question lol.
Want to make sure you can now back up your Orin NX properly?

I think I have successfully backed up the file system and restored it under your prompt. Thanks for your help, I continue to study burning multiple devices at the same time.

1 Like

hello After I run sudo./tools/backup_restore/l4t_backup_restore.sh -b p3509-a02+p3767-0000 The files in the Linux_for_Tegra/tools/backup_restore/images directory are updated, but the system cannot start properly after I run the command to restore the image.
flash procedure.txt (95.4 KB)

flash proceed. txt is my burning process, if you need more detailed log I can also provide.
Did I do something wrong there?

So you flashed the device with the following command using the image you just backed up, but the device failed to boot?

$ sudo ./tools/backup_restore/l4t_backup_restore.sh -r p3509-a02+p3767-0000

Please provide the serial connection log when you boot up the device, and I’ll see if we can go deeper into the issue. Also, I want to make sure that your Orin NX can boot successfully before being restored with the backup image.

Yes, and I’d like to know, sudo ./tools/backup_restore/l4t_backup_restore.sh -r p3509-a02+p3767-000 command Do you burn all backups of.img in Linux_for_Tegra/tools/backup_restore/images to NVME?

Does my recovery history look normal to you?

If you cannot get up, you will be prompted with an Error: Could not detect network connection.

I mean you need to connect your device to the host PC via the micro USB port,
and monitor the boot process with tools like picocom, so we can log and analyze it to find the problem.

This is the startup message detected with DEBUG
start.txt (35.5 KB)

When I plug in the cable and start
network.txt (35.4 KB)
I want to know if my command to restore the mirror is correct.

/Linux_for_Tegra/tools/backup_restore/ Is the README_backup_restore.txt file in the directory reliable?

When I tried executing Workflow 3: To massflash the backup image, Run sudo ./tools/backup_restore/l4t_backup_restore.sh -b -c p3509-a02+p3767-0000 success But run sudo./tools/kernel_flash/l4t_initrd_flash.sh --use-backup-image --no-flash --network usb0 --massflash 5 p3509-a02+p3767-0000 nvme0n1p1 Will fail

There are still errors, and I don’t know where I didn’t execute correctly, but I did fail all the time.

We are now checking if we can reproduce this issue on our device.
Do you fail both when flashing only one device and doing a mass flash?

Yes, I only have one device