Orin NX 8G restore failed with the backup_restore tool

I bought two Orin NX 8G boards(Leetop-SUBKIT_603_ORIN_NX).I call them A1 and A2.
Then I bought a new Orin NX 8G board(Leetop-SUBKIT_603_ORIN_NX) after a month.I call that B1.

I backup A1 with command “sudo ./tools/backup_restore/l4t_backup_restore.sh -b p3509-a02+p3767-0000”,and get ImageA. I can use ImageA to restore A1 and A2 with command “./tools/backup_restore/l4t_backup_restore.sh -r p3509-a02+p3767-0000”

But I can’t use ImageA restore B1.The error shows like “You are trying to flash images from a board model that does not match the current board you’re flashing onto.”

I try to comment script of check refer below link.
Continuing the discussion from Restore JETSON Orin NX failed with JetPack5.1_R35.2.1:

It still doesn’t work.

I generate ImageB with board B1, and I can restore B1 with ImageB successfully.

What can I do something other?

FailedWithModifyshell.txt (95.3 KB)
FailedWithOrignalshell.txt (94.4 KB)
flash_3-1_0_20230728-163610.log (6.7 KB)
flash_3-1_0_20230728-164140.log (6.7 KB)


The flash failure seems just because the ssh key problem as the log says. Nothing to do with the flash script anymore.

Read your error log and it already told you the solution.

I also try remove ssh-key like it showed. Then it need root password when I connect ssh. I don’t have the password.
However, why ImageB works normal?

This is output of ImageB flashing.

FlashSuccess.txt (106.3 KB)

What does that mean it needs password? What did you see ? Any log to share?

I didn’t save the log.
I use the command "ssh-keygen -f “/home/ubuntu/.ssh/known_hosts” -R “fe80::1%usb0”.
And I connect ssh with “ssh root@fe80::1%usb0”, then it let me enter password.


You don’t need to ssh it… you need to start the backup/restore again… No one asked you to ssh it.

It is the script that might ssh… not you…

Okey, thinks, I’ll try again.

When it occured the error above, I send the command "ssh-keygen -f “/home/ubuntu/.ssh/known_hosts” -R “fe80::1%usb0” "
Then restart the restore process. It still occured the same error.

What else can I do?

Share the error log of what you see now…

I had remove the ssh key.

Waiting for target to boot-up...
Waiting for device to expose ssh ......RTNETLINK answers: File exists
RTNETLINK answers: File exists
Device has booted into initrd. You can ssh to the target by the command:
$ ssh root@fe80::1%usb0
Cleaning up...
Log is saved to Linux_for_Tegra/initrdlog/flash_3-1_0_20230731-162502.log 
Run command: 
ln -s /proc/self/fd /dev/fd && mount -o nolock [fc00:1:1::1]:/home/ubuntu/nvidia/nvidia_sdk/JetPack_5.1.1_Linux_JETSON_ORIN_NX_TARGETS/Linux_for_Tegra/tools/backup_restore /mnt && /mnt/nvrestore_partitions.sh -n 
 on root@fc00:1:1::2
/mnt/images ~
nvrestore_partitions.sh: Use the default nvpartitionmap.txt as the index file.
/mnt/nvrestore_partitions.sh: line 415: syntax error: unexpected end of file
ubuntu@ThinkBook:~/nvidia/nvidia_sdk/JetPack_5.1.1_Linux_JETSON_ORIN_NX_TARGETS/Linux_for_Tegra$ ssh root@fe80::1%usb0
The authenticity of host 'fe80::1%usb0 (fe80::1%usb0)' can't be established.
ECDSA key fingerprint is SHA256:U3LbU/bdjgvFh50AXZsd4PzvdZg0JnbqxKqvOX4GiR8.
Are you sure you want to continue connecting (yes/no/[fingerprint])? ^C

please check if you modified the file wrong… because there is a syntax error…

/mnt/nvrestore_partitions.sh: line 415: syntax error: unexpected end of file

I only changed the code below.

#if [ ${BOARD_MATCH} = false ]; then
#	echo "${SCRIPT_NAME}: You are trying to flash images from a board model that does not"
#	echo "match the current board you're flashing onto."
#	exit 1

And this is the script I use.
nvrestore_partitions.sh (12.7 KB)

Why did you remove this “done” …?

#done  ->????????
#if [ ${BOARD_MATCH} = false ]; then
#	echo "${SCRIPT_NAME}: You are trying to flash images from a board model that does not"
#	echo "match the current board you're flashing onto."
#	exit 1

refer this ↓

And you mean just comment out 284~288?

yes… not just copy and paste… you need to think about it by yourself…

Thanks! It works.
Actually I didn’t read the script…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.