Orin NX not recognized when in recovery mode

Hi all,

I have an Orin NX in a older Xavier NX Carrier board by Nvidia. However I am unable to flash it as its not recognized by the SDK manager that its in recovery mode. How do I go about flashing the Orin? I have looked at the pinout compared to the Xavier NX and this carrier board should suffice? Do I have to get a Orin NX compatible carrier board?
Also does the SDK manager support flashing for the Orin NX? I dont see it at all in the hardware list.

Thanks :)

1 Like

Hi r.vries,

You could use Orin NX module + Xavier NX devkit carrier board with NVMe drive to verify.
You might use the following command to flash the board

$ sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" --showlogs --network usb0 p3509-a02+p3767-0000 internal

Thanks for the info. Does the SDK manager not support Orin NX yet?

Yes, Orin NX is not yet supported by SDK Manager.
Please download BSP package and use initrd to flash the board at this moment.

Ive downloaded this BSP: https://developer.nvidia.com/embedded/jetson-linux-r3521
However once running it stops on a lot of “No such file or directory”
What dependancy’s do I need?
Logs (29.9 KB)

You also have to download the Sample Root Filesystem from Jetpack 5.1 release.

and refer to the following instruction to extract them to <Linux_for_Tegra>/rootfs/
Quick Start — To Flash the Jetson Developer Kit Operating Software

Thanks, that helped.
Im still stuck on the following error when executing the flash command
Error: missing readinfofile (/home/username/Jetson_Orin_Nx/Linux_for_Tegra/bootloader/readinfo_t234_min_dev.xml).

Just let sdkmanager download the BSP for you and you won’t have missing files.

Tried it but no luck. Multiple times and also on a different laptop. Are you sure it works?

Are you using standalone Ubuntu18.04 or 20.04 as your host PC?

and Please provide the detail steps you did and flash log for further check.

Hello,i use this command write Jetpack5.1 OS to Orin NX 16GB with my Xavier NX carrier board also not work,can’t detected my device.

please always attach any log file as text file. Also, full log is needed.

And your issue is not same as “not recognized in recovery mode”… Your board is already in recovery mode and can be recognized. Please file new topic for your issue.

Hi @WayneWWW @KevinFFF

Is there a planned date for the SDKManager to support Orin NX devices?


I retried above steps again (Quick Start — Jetson Linux Developer Guide documentation)
And it worked on this try, my OS is Pop OS (Ubuntu 22). I used the following packages:
I was trying to do it in a docker container before and I think this might have caused issues.

${L4T_RELEASE_PACKAGE} = Jetson_Linux_R35.2.1_aarch64.tbz2
${SAMPLE_FS_PACKAGE} = Tegra_Linux_Sample-Root-Filesystem_R35.2.1_aarch64.tbz2

I too would like to know

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.