Orin NX UEFI Secure Boot

I’m working on Orin NX 8GB + Xavier NX developer kit.
I want to enable UEFI Secureboot at Flashing Time.

I applied this patch.

I made keys, and used following command to flash. But it failed with busy spin error.

Linux_for_Tegra$ sudo ./flash.sh --uefi-keys uefi_keys/uefi_keys.conf p3509-a02+p3767-0000 nvme0n1p1
E> Error in command_complete 18000 int_status
E> Sending CMD_SD_SEND_IF_COND failed
E> Error opening sdcard-0
E> Failed to initialize device 6-0
C> Storage init failed
C> Task 0x0 failed (err: 0x39390706)
E> Top caller module: SDMMC, error module: SDMMC, reason: 0x06, aux_info: 0x07
I> Busy Spin

uart.txt (16.6 KB)
host-pc.txt (73.8 KB)

Board: Orin NX 8GB + Xavier NX developer kit
L4T: R35.3.1
host-pc: ubuntu 18.04.6

What command enables UEFI Secureboot at flush time for Orin NX?

please see-also Topic 248137, comment#51, thanks

Thank you for your reply.
I read your shared topic.but it is different from my usecase.
I only want to try UEFI secureboot, not disk encyption.

I think flash.sh is not support Orin NX.
So, I want to know the substitute command.

How can I enable UEFI Secureboot at flush time on Orin NX?

Hi, @JerryChang I stil need your help.
I want to clarify the following two questions.

Dose “flash.sh --uefi-keys” support OrinNX + XavierNX carrier board?
How can I enable UEFI Secureboot at flush time on Orin NX without disk encyption?


hello S.Harumoto,

you’ll need to execute this script for flashing Orin NX, i.e. $OUT/Linux_for_Tegra/tools/kernel_flash/l4t_initrd_flash.sh
and… it’s -p options for sending commands to flash.sh when generating the image for internal storage.

anyways, let me check this internally for test results…

1 Like

Hi, @JerryChang
Is there any new information from the results of the internal check?

FYI, we are still working on it… to enable UEFI secureboot in flashing time by Orin NX/Orin Nano.

1 Like

hello S.Harumoto,

you may refer to Release Notes (r35.4.1), UEFI secure boot has been enabled in Jetpack-5.1.2 release version.

1 Like

Thanks for letting me know.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.