Orin NX unable to boot/flash

Is there any approach to wipe the nvme drive without boot up? I guess reflashing an empty disk should work fine.

please directly download your BSP folder by using sdkmanager. Do not do it by yourself first.

Complete process:

complete.txt (234.9 KB)


So does your rootfs really have “init” binary in /sbin/init?

Just a reminder, you need to provide the uart log and host log at same time when doing any update.

The UART log can have 100 reasons to fail, but the host log may always describe them in same way. So please make sure UART log is also attached.

Honestly I’m not 100% sure. I tweaked some values when building yocto, and right now I can’t read the content on nvme. But I’ll say it’s possible that init is indeed missing. Is there anything I can do if init isn’t there?

Besides, I forgot to upload UART log, but it was still missing init & kernel panic. If you need it I can capture again.


No, I didn’t ask you to check your nvme. I know you cannot access it. I mean check Linux_for_Tegra/rootfs/sbin/.

You need to at least know learn this file comes from…

Also, please just forget about yocto at this moment. That is just making noise.

Please make sure your step is clean without any other things installed. Only the tool provided by NV should be in use.

Yes. There is an “init” in Linux_for_Tegra/rootfs/sbin/. When you just say rootfs, it’s a little ambiguous.

I suppose that since the flash process never go beyond “wait for bootup”, even though init is in L4T directory, it won’t be written into nvme, right? As all erasing and writting stuff happens after device exposing SSH.


Could you install the directory by sdkmanager and run the command again?

This was what I keep asking for. You don’t need to download BSP and rootfs manually. Just let sdkmanager do this work for you to make sure nothing gets missing.

The only thing you need to do is run initrd flash command in the BSP folder installed by sdkm.

I’ll try. Do I need to run apply-binaries.sh?

No, you don’t need to run anything except the initrd flash tool. Those things are all handled by sdkmanager already.

I let sdkmanager do the prepare job and then execute initrd flash command, the results remain the same.

host_logs_sdkmanager.txt (242.9 KB)
uart_logs_sdkmanager.txt (87.0 KB)


Do you have Xavier NX devkit on your side to test instead of using your custom board?

Also, how about other cases like other nvme drive or using usb drive?

Hi, @WayneWWW. I’m using SDK Manager on my host machine. I don’t see an option in the Target Hardware for Jetson Orin NX modules (I do see an option for Jetson AGX Orin modules). According to this thread (Orin NX not recognized when in recovery mode - #5 by KevinFFF) Orin NX isn’t supported by SDK manager yet. So how can I download the BSP via sdkmanager? Thanks in advance!

I think you can choose AGX Orin. Jetson devices all use the same BSP package.

1 Like

I’ll try USB flash. Can I use a 16 GB drive, or a larger one is required?

please use at least 32GB.

I solved it. The solution is to manually enter UEFI setup and choose Nvidia RCM kernel to boot, during the “wait for boot up” phase. Then everything just goes on as usual. I don’t know why the default boot option was always wrong though…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.