OS X 10.5.8 and 285GTX kernel panic 10.5.8 update causes kernel panic

Hi All,

I attempted a software update on my 2008 Mac Pro to 10.5.8 this morning and on restart a kernel panic resulted – grey screen with " … you must restart
you computer …" message in 4 languages appeared. After about 2.5-3 hours of phone support by Apple they had scheduled a service call to replace my
motherboard and memory card risers. They thought the software update and boot problem were not related.

A few hours later the tech called me back. He had just been in some training and asked if I had a 285GTX, which I did. My machine had originally shipped
with an 8800GT. He suggested I put the 8800GT back in, I did, and success!!

I originally had trouble with the 285GTX back in early JUNE, went on vacation, and on return read the 6/26/2009 sticky by tmurray that I should make sure
I reinstall the original driver for the 285GTX that came in the box with the card and install a special version of the 2.2 toolkit by following a link in the
sticky post. Perfect, with both the regular MAC and CUDA working fine.

After I was back up today I went to the CUDA MAC OS X page and saw version 2.3 with an explicit link for drivers for the 285GTX and 4800 cards which
stated these would work for 10.5.2 and later AS WELL AS Snow Leopard. So I installed this driver - 2.3.1 I believe was the number - reinstalled the 285GTX,
but again a kernel panic.

SO I GUESS THIS IS FOR THE FOLKS AT NVIDIA/APPLE - any idea when you will have compatible drivers for 10.5.8 and the 285GTX under which CUDA will
work properly? Granted, I have the 8800GT but the main reason I purchased the 285GTX was the need for double precision under CUDA, so the 8800GT
leaves me dead in the water. Plus, all my $450 285GTX is good for at the moment is for staring at and becoming angry/sad.

So under 10.5.8 I know of no available driver with which the machine will boot. Is there another driver in the works or other fix that would help?

Thanks, Hans

http://www.nvidia.com/object/GeForce_MacOSX_18.5.2f16.html

try that

Hi tmurray,

Many thanks! I will install the driver and give it try.

Can you tell whether the CUDA SDK/toolkit version 2.3 will work with this driver? And if you know, what is the

difference between this driver and the 2.3.1 version posted on the Nvidia download page?

Thanks again, Hans

what I linked is a full display driver (with support for 2.3), while the CUDA driver is just the CUDA component of the driver.

Hi tmurray,

I downloaded the GeForce_MacOSX_18.5.2f16 driver, reinstalled the 285GT, and SUCCESS!

However, I then downloaded the 2.3.1 CUDA driver (note - while the webpage says this is for the 4800 and 285GTX, the

release notes specifically says the the 2_3_0 version is for all GeForce cards.) I then got the 2.3 toolkit and SDK, built

the demos (now in /Developer/GPU\ COmputing) and when I run ./devicequery I get

boussinesq:release johnston$ ./deviceQuery

CUDA Device Query (Runtime API) version (CUDART static linking)

There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”

CUDA Driver Version: 2.30

CUDA Runtime Version: 2.30

CUDA Capability Major revision number: 9999

CUDA Capability Minor revision number: 9999

Total amount of global memory: 4294967295 bytes

Number of multiprocessors: 16

Number of cores: 128

Total amount of constant memory: 65536 bytes

Total amount of shared memory per block: 16384 bytes

Total number of registers available per block: 8192

Warp size: 1

Maximum number of threads per block: 512

Maximum sizes of each dimension of a block: 512 x 512 x 64

Maximum sizes of each dimension of a grid: 65535 x 65535 x 1

Maximum memory pitch: 262144 bytes

Texture alignment: 256 bytes

Clock rate: 1.35 GHz

Concurrent copy and execution: No

Run time limit on kernels: No

Integrated: Yes

Support host page-locked memory mapping: Yes

Compute mode: Default (multiple host threads can use this device simultaneously)

Test PASSED

Press ENTER to exit…

My PATH and DYLD_LIBRARY_PATH variables are properly set.

Any ideas? Must I revert back to version 2.2?

Thanks, Hans

Reinstall the 2.3.1 driver, and everything should work.

Hi tmurray,

Success!!!

One last question if I may: I noted, as was the case under 2.2, that the device clock rate is reported as 0.60GHz. If I run

an example, e.g. nbody, and then deviceQuery again I see 1.48GHz. If I wait a minute or so deviceQuery returns 0.60GHz

again.

Is the GPU throttling back, and if so, is there an API call to make sure it is “fully awake” before running a code.

Thanks again for all the help,

Hans

This one has been discussed at length elsewhere on this forum and also on forums.macrumors.com and forums.evga.com. First of all, some Mac Pro 09 users are now reporting that the card runs at 1.48 by default anyway, which is baffling us.

The rest of us are waiting for a power management fix, which is taking a long time to arrive. Meantime, what I do is to run postProcessGL in another X window as a background process (this is the teapot you will see referred to here and there). It keeps the clock up at 1.48. It does consume some resources though, but the Monte Carlo option pricing examples run about 10 times faster with it running than not (the memory clock is slowed down even more it seems). The histogram examples benefit less from this trick.

If you have two or more GPUs, maybe in a hacked system, you can target the teapot to run on the lazy GPU.