OSError: libcurand.so.10: cannot open shared object file: No such file or directory

Hi I tried the nvidia Pytorch package(the .whl installation) and I tried the pytorch docker on your site and I followed all the instruction on this site : PyTorch for Jetson but I have this new error each and every time no matter what I do :
root@ubuntu:/home/depth# /usr/bin/python3 /home/depth/stereoVision.py
Traceback (most recent call last):
File “/home/depth/stereoVision.py”, line 6, in
import torch
File “/usr/local/lib/python3.6/dist-packages/torch/ init .py”, line 196, in
File “/usr/local/lib/python3.6/dist-packages/torch/ init .py”, line 149, in _load_global_deps
ctypes.CDLL(lib_path, mode=ctypes.RTLD_GLOBAL)
File “/usr/lib/python3.6/ctypes/ init .py”, line 348, in init
self._handle = _dlopen(self._name, mode)
OSError: libcurand.so.10: cannot open shared object file: No such file or directory

I looked online and on the forum for some fixes and I tried them all and none of them worked. I tought that the docker would fix that but it didnt. I have the jetpack 4.5 and I tried the pytorch version 1.8.0 and 1.9.0 and 1.10.0 and their corresponding version of torchvision. Is there any thing I could do?


Hi @user159451, do you have CUDA Toolkit and cuDNN installed on your TX1?

Can you check the /usr/local/cuda/lib64 directory for the libraries?

$ ls /usr/local/cuda/lib64

libcublasLt.so                libcuinj64.so              libnppc.so.10             libnppif_static.a        libnpps.so.10
libcublasLt.so.10             libcuinj64.so.10.2         libnppc.so.     libnppig.so              libnpps.so.
libcublasLt.so.     libcuinj64.so.10.2.300     libnppc_static.a          libnppig.so.10           libnpps_static.a
libcublasLt_static.a          libculibos.a               libnppial.so              libnppig.so.   libnvblas.so
libcublas.so                  libcupti.so                libnppial.so.10           libnppig_static.a        libnvblas.so.10
libcublas.so.10               libcupti.so.10.2           libnppial.so.   libnppim.so              libnvblas.so.
libcublas.so.       libcupti.so.10.2.175       libnppial_static.a        libnppim.so.10           libnvgraph.so
libcublas_static.a            libcurand.so               libnppicc.so              libnppim.so.   libnvgraph.so.10
libcudadevrt.a                libcurand.so.10            libnppicc.so.10           libnppim_static.a        libnvgraph.so.10.2.300
libcudart.so                  libcurand.so.    libnppicc.so.   libnppist.so             libnvgraph_static.a
libcudart.so.10.2             libcurand_static.a         libnppicc_static.a        libnppist.so.10          libnvperf_host.so
libcudart.so.10.2.300         libcusolver.so             libnppicom.so             libnppist.so.  libnvperf_target.so
libcudart_static.a            libcusolver.so.10          libnppicom.so.10          libnppist_static.a       libnvrtc-builtins.so
libcufft.so                   libcusolver.so.  libnppicom.so.  libnppisu.so             libnvrtc-builtins.so.10.2
libcufft.so.10                libcusolver_static.a       libnppicom_static.a       libnppisu.so.10          libnvrtc-builtins.so.10.2.300
libcufft.so.        libcusparse.so             libnppidei.so             libnppisu.so.  libnvrtc.so
libcufft_static.a             libcusparse.so.10          libnppidei.so.10          libnppisu_static.a       libnvrtc.so.10.2
libcufft_static_nocallback.a  libcusparse.so.  libnppidei.so.  libnppitc.so             libnvrtc.so.10.2.300
libcufftw.so                  libcusparse_static.a       libnppidei_static.a       libnppitc.so.10          libnvToolsExt.so
libcufftw.so.10               liblapack_static.a         libnppif.so               libnppitc.so.  libnvToolsExt.so.1
libcufftw.so.       libmetis_static.a          libnppif.so.10            libnppitc_static.a       libnvToolsExt.so.1.0.0
libcufftw_static.a            libnppc.so                 libnppif.so.    libnpps.so               stubs

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.