OTG fail

Hi,
My Jetson Nano board micro USB OTG just stopped working - it is being improperly detected by Linux/Win.
On linux, dmesg command shows
[ 247.167064] usb 1-1: new full-speed USB device number 5 using xhci_hcd
[ 329.931065] usb 1-1: new full-speed USB device number 6 using xhci_hcd
[ 330.059086] usb 1-1: device descriptor read/64, error -71
[ 330.571093] usb 1-1: device descriptor read/64, error -71
[ 334.571135] usb 1-1: new full-speed USB device number 8 using xhci_hcd
[ 334.699256] usb 1-1: device descriptor read/64, error -71

I tried to re-flash with Nvidia provided ubuntu image but still the l4t-readme directory is not shown on the host machine. I tried different USB cables and power supplies, but still no USB mass storage.

Any ideas? it sued to work - is this HW issue?

update - now on plugging USB dmesg don’t even show it on the logs… (no error, no nothing…)
is there maybe some firmeware update/rest that might fix this?

Is this NV devkit or custom carrier board?

I have a Jetson Nano dev kit.(149$ from Amazon…
Don’t know if that matters, but I used it to flash imgs onto devices using QDL application

Hi,

I think a proper full reflash from sdkmanager may be necessary here.

Please prepare another x86 ubuntu 18.04 host and install sdkmanager. Then use this host to flash your jetson.

Hi WayneWWW,
When I run the SDK manager, on the first step under hardware configuration target hardware it says “could not detect board”… (I can chose manually the Jetson nano product, but the fact that the board is not being even acknowledge via the micro usb port makes me doubt I could re-flash it using the SDK manager…)

Are you using the cable which comes with a Nano? Most of the “charger” cables have incredibly bad quality (maybe one or just two strands of 32 gauge or smaller copper). I would guess two out of three models of charger cable out in the stores will fail.

The other issue which often comes up is if the host is a VM. VMs need USB pass-through to be set up correctly, and there is nothing the Jetson flash software can do to work around that.

If it is neither of the above, sometimes simply changing to a different USB port helps.

As far as the recovery mode itself goes, the recovery jumper is like the shift key on a keyboard when trying to type a capital letter. As long as the jumper is held during either (A) a power on or a (B) power reset, then the jumper does not need to be held any longer than that. If you perform more than one recovery mode operation, e.g., clone then flash, or try to flash twice, then recovery mode must be restarted for each operation.

As linuxdev said in above comment, you need to put the board into recovery mode first so that sdkmanager can detect your board.

I tried entering recovery mod, followed instructions in the forums, but that didn’t helped…
(I use pure WIN or Linux machine, no VM)

As for now, I switched to another Nano board and so far (~2 days) the USB OTG still works as expected, so I hope what I saw with the first board was just a glitch, and it won’t happen again on other boards…

Hi,

If you didn’t try this before, it is most likely your method to put board into rcm is not correct.

You can try to put your 2nd nano board into recovery mode and see if your host PC can detect it or not.

Your data won’t get erased if you don’t start the flash process. (and reboot the device without jumper can make your board return from recovery mode)

This is just to make sure the method you put the board into recovery mode is correct or not.

Windows (without a VM) is not capable of flashing a Jetson (which is what we are talking about if we are on the topic of flashing). Just to emphasize what @WayneWWW said, recovery mode itself does not change anything on the Jetson, it only makes the Jetson capable of being understood by the custom USB drivers used in flash. Nothing is harmed by checking recovery mode. When one does operate on a Jetson in recovery mode it is required to restart recovery mode if performing more than one operation. For example, you can’t flash twice without first resetting recovery mode, and you cannot clone then flash unless recovery mode is reset between clone and flash.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.