Overclocking doesn't show on hybrid mode with Fedora linux even tho coolbits is turned on in the config

Option Coolbits doesnt work when xorg is using the AMD GPU to render the screen even tho Coolbits is added to the config file (nvidia.conf in etc/x11/xorg.conf.d)

This issue is not present for Ubuntu or Arch based distros , only happens on Fedora 37/38

Once Option PrimaryGPU is set to “yes” the overclocking options are unlocked on this laptop but that is not a long term solution due to the higher fan noise and temps