P2597 carrier board, not seeing any output on J21 SPI pins

I have a P2597 carrier board (PN *-501 D), running L4T version of Ubuntu.

I followed the TX2 SPI enablement directions on elinux.org, and I’ve tried everything I can think of to get something to show up on the SPI bus.

I see /dev/spidev3.0, and I can “echo ‘Hello World’ > /dev/spidev3.0”, but the logic analyzer I attached to J21 pins 19, 21, 23, and 24 don’t show the slightest change.

The /dev/spidev3.0 file does exist, and it correlates with the spi master at 0x3240000 (/sys/bus/platform/devices/3240000.spi/spi_master/spi3 shows the association between the device and spi master 3).

If I run “sudo spidev_test -D /dev/spidev3.0”, the logic analyzer doesn’t see anything, and if I remove the analyzer and use a jumper to connect pins 19 and 21 together, I would expect spidev_test to receive back exactly the data it sent, but I just get back zeroes.

I’m not really clear on how to verify the pinmux configuration, although my understanding is that the default image should be pre-configured to enable SPI1 on the development board.

What should my next step be in debugging this?

Have a reference to below topic.