Packer with Nano - error during apt update

Hi,

I’m trying to automate the flash of my Nano OS, using Packer + https://github.com/mkaczanowski/packer-builder-arm.
I can now create an image from it to put on an SD card, but now I would like to provision the Nano to have all the packages I need.
I added a provisioning step of

sudo apt-get update

But I encounter the following error:

==> arm: E: The repository ‘https://repo.download.nvidia.com/jetson/ r32.4 Release’ does not have a Release file.

I don’t have this problem on my Nano which is already configured (with user and all).

Also, is it possible to automate the user creation from the command line (during the Packer provisioning)?

Any idea…?

Best

Hi,

Such error means this repository is not available for your current ubuntu.

But I just run a “apt update” from the last official image of Jetson Nano. This only occurs when trying to do that with Packer, however it’s OK once the system is in place…

Then I think it is fine. No need to worry about it.

Yes but it returns an error which stop the provisioning in that case.

Hi,

I just tried to understand your problem more clearly. Your packer is like chroot to mount the system image on your host and you tried to run apt-get under this system and hit error.
Is my understanding correct?

Maybe you need to check the rule of PPA and ubuntu repository to find out why it gets this error. We don’t support such case over host.

Yup, exactly.
Alright, I’ll have a look at this! Thanks :)