Patch for driver 375.39 with stable kernel 4.11

Hi guys. I was wondering if there is a patch available for driver 375-39 (the current Debian unstable/testing DKMS driver) for the newly released stable kernel 4.11? I have tried to search but found either conflicting information or patches that are for newer drivers only.

Thanks!

It a lot easier patching 375.66
kernel_4.11.patch.txt (533 Bytes)

--- a/kernel/nvidia-drm/nvidia-drm-linux.c
+++ b/kernel/nvidia-drm/nvidia-drm-linux.c
@@ -20,6 +20,8 @@
  * DEALINGS IN THE SOFTWARE.
  */
 
+#include <linux/version.h>
+
 #include <linux/module.h>
 #include <linux/slab.h>
 #include <linux/err.h>
@@ -196,7 +198,11 @@
 module_exit(nv_linux_drm_exit);
 
 #if defined(MODULE_LICENSE)
+#if LINUX_VERSION_CODE > KERNEL_VERSION(4, 10, 0)
+  MODULE_LICENSE("Dual MIT/GPL");
+#else
   MODULE_LICENSE("MIT");
+#endif
 #endif
 #if defined(MODULE_INFO)
   MODULE_INFO(supported, "external");

Hey all! This worked on 4.11 Kernel and the 375.66 Nvidia drivers! Woot!! Many thanks. I just don’t know why Nvidia is not doing it. They must really hate Linux. That’s going to cost them because AMD and Intel really seem to love it. ;-)

Nvidia probably need to consult their lawyers first before they change licence if they go that route.

This looks really bad for nvidia. I really like their products. but…

Btw, the patch also worked for me. Basically changed MIT to Dual MIT/GPL

If you don’t need the nvidia-drm module (which is the module that needs relicensing) then with 375.66 simply exclude the module, no need to patch. See http://rglinuxtech.com/?p=1970

I wont be an issue for fedora much longer as I asked Laura if she could backport the upstream fix.

http://pkgs.fedoraproject.org/cgit/rpms/kernel.git/commit/?h=f26&id=c7cad27274c3c303f5bfc09491e3d1f43f1357d1

Yeah, eventually this issue will go away.

I had notified Greg aswell. v4.11.1 will fix it for all. The patch is now officially queued.

Unfortunately I couldn’t get this to work. Keep in mind I’m using the Debian Testing dkms driver which is still at 375-39. I don’t know how to dump 375-66 into it, or if that’s even a good idea. Thanks to all who replied here!

Well, for that you need some extra patches you might find in my git-repository. Check the PKGBUILD file on how to apply them. Else you may wait for v4.11.1 which fixes it also without a need of patches.

Fedora 26, kernel 4.11.1, NVIDIA driver 375.66 -> worked

Fedora 26, kernel 4.11.1, NVIDIA driver 381.09 -> failed compiling