Path Tracing Annotators are not available in Omniverse API

Hello,

I tried to run the PathTracing annotator example using the following doc and it would not collect the PathTracing annotator data.

Here is the issue, PT annotators are not listed in the AnnotatorRegistry() class when calling _annotators.
Below is the error I receive:
raise AnnotatorRegistryError(f"No annotator of name {name} registered")

Is there a way where I can get PT annotator data?

Here is a list of available annotators when calling _annotators.
OmniverseAPI_Annotators.txt (5.8 KB)

Here is the code:

async def test_pt_anno():
# Set rendermode to PathTracing
rep.settings.set_render_pathtraced()
rep.settings.carb_settings(setting=‘rtx-transient.aov.enableRtxAovs’, value=True)
rep.settings.carb_settings(setting=‘rtx-transient.aov.enableRtxAovsSecondary’, value=True)

# Attach render product
W, H = (1024, 512)
cam = rep.get.prim_at_path('/Replicator/Camera_Xform')
render_product = rep.create.render_product(
    camera='/Replicator/Camera_Xform',
    resolution= RESOLUTION
)

anno = rep.AnnotatorRegistry.get_annotator("PtGlobalIllumination", device="cuda")
#anno = rep.annotators.annotators.annotators.get("PtGlobalIllumination", device="cuda")
#anno = rep.AnnotatorRegistry()
#print(anno._annotators)
#print(anno._annotators)
anno.attach([render_product])

await synth.orchestrator.step_async()
print("getting data")
data = anno.get_data(device="cuda")
print(data)
#print(data.shape, data.dtype)
# (512, 1024, 4), float16

In a separate file I run

asyncio.ensure_future(lights.test_pt_anno())

Here are my settings:

  • IsaacSim 2022.2.1
  • Windows 10

@InfraredLaser i am just another OV user, but does the issue persist in the latest Isaac Sim (2023.1.1)?

@Simplychenable
I ran a small test using v2023 with the above code.
It looks like PathTrace annotators are in v2023 and not in v2022.

Calling rep.scripts.annotators.get_registered_annotators()in 2023 lists the PT annotators. Version 2022 does not seem to have this API.

I’m looking to see if there is an API which exposes PT annotators in v2022.

Hi there, if the PT annotators are only available starting v. 2023 you will need to update the a newer version to get access to these features.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.