PCA9685 -> Jetson TX1 I2C Communication Write Byte Error

I tried connecting PCA9685 Servo Controller to Jetson TX1 through I2c Bus 1.
using the command i2cdetect it is showing me that the address of the device is 40.
Pinout -
GND J21-2 -> PCA9685 (GND)
VCC J21-6 -> PCA9685 (VCC)
SCL J21-28 -> PCA9685 (SCL)
SDA J21-27 -> PCA9685 (SDA)

I used the following code https://github.com/jetsonhacks/JHPWMDriver
but while running the servoExample it’s showing me the error WriteByte Error: 9.
Also, this issue is currently open on the Github repository. How to resolve this issue?

Also how to connect Arduino through I2c Bus 0 to Jetson TX1. I was not able to find relevant tutorials regarding it.

Hi, there is address conflict on 0x40. J21-3 and J21-5 are for Bus 0 (3V3).

I changed to Bus 0 and ran it with root permissions and the code worked. Thanks for the support.
I wanted to extend more I2C devices on the same bus or different bus.
PCA9685 Servo controller has SDA and SCL pins to connect more devices in series. I tried adding an I2C slave to the pins but the slave is not detected. Only 0x40 and 0x70 are shown using the i2c-tools.
I also tried connecting the same sensor to bus 1, but there was no address detected either. What might be the issue?

I think you’d better to ask vendor for help, it seems like a driver problem of PCA9685.

Regarding the sensor to bus 1, what’s the address of the sensor? Basically the I2C bus itself should have no problem.

The i2cdetect tool is not showing any address on the bus 1. With the same sensor connected to bus 0, the i2cdetect tool is showing the address 0x70.