Pcie Issue on Jetson Tx2

I tried Pcie card on windows and linux in x86 it is working.But i tried in arm64 i am getting the following
I tried to get my base address of Pcie i got it After that pci_resource_start().Before that i checked it is port mapped or io mapped by if (bar_flags & IORESOURCE_IO) i got it port io and io size i got 256 bytes.from 0x1000 to 0x10ff .So from that i need to access the register values from the pci configuration by byte=ioread8(baseaddr+0x74);.After that i am getting these errors

rtnic: map_ioaddr: 0xf596000
[ 162.292784] CPU3: SError detected, daif=140, spsr=0x80000045, mpidr=80000101, esr=bf000000
[ 162.293996] CPU0: SError detected, daif=1c0, spsr=0x800000c5, mpidr=80000100, esr=bf40c000
[ 162.294001] CPU5: SError detected, daif=1c0, spsr=0x800000c5, mpidr=80000103, esr=bf40c000
[ 162.294005] CPU4: SError detected, daif=1c0, spsr=0x800000c5, mpidr=80000102, esr=bf40c000
[ 162.295540] ROC:IOB Machine Check Error:
[ 162.295548] Address Type = Secure DRAM
[ 162.295603] Address = 0x0 (Unknown Device)

Can you help that Pcie supported by jetson in arm64 or not if it is supported then how i can access the register configuration space from pcie through Jetson tx2.

Can you please share your ‘sudo lspci -vv’ output? Also, can you please confirm that even in x86 system, this PCIe card of yours has only IO resource that gets exposed to system and not memory?
How did you get ‘bar_flags’ ? Is it through pci_resource_flags() API?
Also, if there is an option to expose resources of the device as ‘memory’ instead of ‘IO’, can you please do that and see if that resolves the issue?