PCIE1_RST always low on NX board

I probed the PCIE1_RST, it seems it output a high pulse when powering up, then goes low forever. Is this OK?

Thanks.

Hi, are you testing on devkit with default settings? If so, it should be no problem.

We have devkit and we also designed our own carrier board. When no PCIe device plugged. We probed the reset signal, it output two short high pulses, then goes low forever. Is this normal?

Thanks.

After disable power down and clkreq in the device tree. The dmesg output:

~$ dmesg | grep tegra-pcie
[    2.257840] tegra-pcie-dw 14160000.pcie: Setting init speed to max speed
[    2.262011] tegra-pcie-dw 14160000.pcie: Before RST# assertion
[   12.634961] tegra-pcie-dw 14160000.pcie: After RST# de-assertion and 5s delay
[   13.146321] tegra-pcie-dw 14160000.pcie: link is down
[   13.146450] tegra-pcie-dw 14160000.pcie: PCI host bridge to bus 0004:00
[   13.147826] tegra-pcie-dw 141a0000.pcie: Setting init speed to max speed
[   13.148029] tegra-pcie-dw 141a0000.pcie: Failed to get 3V slot regulator: -19
[   13.148040] tegra-pcie-dw 141a0000.pcie: Failed to get 12V slot regulator: -19
[   13.258228] tegra-pcie-dw 141a0000.pcie: Before RST# assertion
[   23.386987] tegra-pcie-dw 141a0000.pcie: After RST# de-assertion and 5s delay
[   23.494941] tegra-pcie-dw 141a0000.pcie: link is up
[   23.495252] tegra-pcie-dw 141a0000.pcie: PCI host bridge to bus 0005:00

There are about 5s delay before RST# goes low, and 5s delay after RST# goes low, but the link is still down.

Any help?

Thanks.

Hi, do you mean you met such problem when plug in PCIe device? Or you just found it went low forever without device? What’s the behavior on devkit? Does it only happen on your custom board?

It’s on our custom carrier board. It seems this still the FPGA late setup problem. After adjusting the delay time, it works now.

BTW: Are there any patch or plan to add “rescan function” after entering Linux for NX module?

Thanks.

Please check if below would help or not.

echo 1 > /sys/bus/pci/rescan

No, it won’t work for me.