Per-display VSync CPU Interrupt in Linux looking to reduce cpu interrupts...

In tuning my laptop for lower-power consumption using the PowerTOP utility ( from Intel, it indicates that the nvidia driver creates 120 interrupts from idle per second. At the time, I had two displays connected and used nvidia-settings to disable the secondary display. Immediately, this went down to 60/sec, which sounds quite obvious to me that the 60Hz refresh rate raises an interrupt every VSync cycle.

I have tried disabling sync to vsync in nvidia-settings, though this does not seem to have an effect. Does anyone know how to mask this interrupt since it is probably not used in 2D mode?

PowerTOP’s “tips and tricks” page indicates

edit: also note that removing Load “glx” from xorg.conf has no effect, except that glx stops working ;)

Does nVidia’s driver have a similar issue? Thoughts or ideas? If this is the wrong place to post, please direct me to where this topic should be placed. Thank you!


Not sure which forum this belongs in (the Hardware/Forceware Drivers forum looks to be almost all Windows discussion), but this forum is definitely not the right place. Sorry. :(