PerfKit compatibility with GeForce GT 640M LE

Hey all,

From reading the specs, my graphics card should be compatible with NSight but I cannot get the PerfKit API to work. When I run “NvPmApiQuery --names” to list the counter names I get:
device 0: GeForce GT 640M LE
Unkown API type
EnumerateCounters failed

Is there something I’m not doing right or is the video card just not compatible? If so what other ways are there for me to get real-time information about the GPU in my program?


Please specify the api type as follows:

NvPmApiQuery --names --cuda 0 or
NvPmApiQuery --names --gl

The message provided wasn’t clear, so we will address that.

Thanks for clearing that out but I still have problems. When I initialize and setup the perfkit API in my app, I cannot get any data back from the sampler. Even the running the samples provided(for both D3D and OpenGL) I get garbage values outputted. Here is a screenshot of the D3D app running:

After debugging I found that I can’t even register my counters
GetNvPmApi()->AddCounterByName(mNVPMContext,“gpu_idle”); returns NVPM_ERROR_INVALID_COUNTER
also GetNvPmApi()->Sample(mNVPMContext, NULL, &unCount); returns NVPM_ERROR_INVALID_CONTEXT
which is wierd, because upon initialization(doing it exactly as specified in the User Guide) everything seems fine…


I am sorry to hear that you are having problems using PerfKit.

Can you provide the following information:

  1. Operating system (version and bitness)
  2. NVIDIA Driver Version
  3. PerfKit SDK version

Sure, here it is:

  1. Windows 7 Ultimate Service Pack 64 bit
  2. Driver Version: 327.23
  3. I installed perfkit several days ago which would be version 3.1

Edit: Updated Driver to 327.23 today

Bump. Please, I really need a fix for this. I tried downloading the Nsight for VS2012 plugin and it won’t display graphs either.

Hi Morji,

Since you mentioned that your GPU is a mobile part (GeForce GT 640M LE), are you able to turn off optimus on the laptop? If you can, do so, and try again.

I tried via the Nvidia Control Panel - 3D Settings - Global Settings - Prefer High-Performance Nvidia processor but no result as of yet

I also tried checking if I can disable Optimus from BIOS but it contains no GPU options at all. Anything else I can do?

Hello, I am sorry for bumping this old thread, but after awhile of searching I have found no solution to this and I am desperate to get this working. I am developing using DirectX 11, doing GPGPU work and I need to be able to monitor the GPU stats. Is there any way to get this working?