Performance Levels 980 / pstate / PowerMizer

I have a problem using my GTX980 in kubuntu 14.04 with memory full speed.
nvidia 343.22 drivers are installed.

my compute application only uses level 2, so the memory speed stays around 6Ghz instead of 7Ghz,
I tried to force the pstate with some tweaking in xorg.conf but it does not work.

Option  "Coolbits" "12"
Option  "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerLevel=0x1; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"

Setting up a new fan speed on the 980 works in powermizer. But where is the trick to get on faster pstates, or edit the memory clock of level 2 to match the max performance. btw. the 750ti in the same system max out easily.

ideas are welcome :)

screenshot powermizer:
http://i.imgur.com/5bbTNhG.png
narf. A newbie account could not use the IMG tag… sorry for just linking.

Sorry to be ultimate necro, but this question was never answered, and I am also experiencing it now…

Same story as OP, I OCed my 970, but the memclock settings are only applied to perf lvl 3, and the card runs on perf lvl 2 on load.

Any ideas?