Performance problems when plugging second monitor into GPU (RTX 3060Ti, driver 515)

i recently added another screen to my setup, which i plugged directly into my graphics card next to my primary screen. unfortunately, this seems to be causing strange performance issues, even if the screen is not actually active in my configuration and not used to display anything, example being the mouse slightly “freezing” whenever i open settings app. this does not happen when i plug the screen into the mainboard, however when i then try to output to the screen using

xrandr --output HDMI-0 --mode 2560x1440 --rate 144.0 --scale 1x1 --output DP-3 --same-as HDMI-0 --mode 1920x1080 --rate 144.0 --scale 1.333x1.333

gnome seems to crash and i am logged out. i am supecting that this is because the ports on the mainboard are managed by the processors integrated gpu. is there a way to either make this work using the mainboard port, or fix the performance problems when plugged directly into the 3060? i would be grateful for any assistance with this and will provide further information as needed

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

1 Like

Thank you for your response! I have attached the bug report

nvidia-bug-report.log.gz (466.9 KB)

Please try setting kernel parameter
Furthermore, please check the gpu usage reported by nvidia-settings while e.g. watching a video, in the logs it was 0% so the gpu wasn’t clocked up. so there might even be a hardware issue involved.

1 Like

Setting this kernel parameter seems to have fixed the performance penalty i’ve been getting in game with the monitor plugged in, the issue of mouse lagging on the desktop when opening certain new windows still persists though. when watching a youtube video at 1080p, my gpu usage hovers between 15 and 40 percent, mostly in the high 20s low 30s.

Please create a new nvidia-bug-report.log with lagging mouse or running video.

1 Like

this one was made right after opening steam, which causes the worst mouse lag for me, while watching a video
nvidia-bug-report.log.gz (650.3 KB)

Can you possibly detach both of your DVD drives and check if that changes anything?

1 Like

i unplugged the sata cables of both dvd drives, this does not seem to change anything. nonetheless, i have created another bug report, same situation as the previous one
nvidia-bug-report.log.gz (512.5 KB)

It’s really weird that just running steam uses 64% gpu at max clocks so there’s something wrong but I can’t see the reason, apart from that everything seems to be perfectly fine. Is ist possible to disable the amd igpu in bios to check if that has some influence on this?

1 Like

disabling the igpu seems to fix the lag problem, however the entire desktop now feels choppy and is much less responsive. windows are visibly jerky when being dragged around. this also only occurs when i have the monitor plugged into DP-3 again. i also had another monitor plugged in that was managed by the igpu that i now cannot use with igpu disabled. bug report is attached
nvidia-bug-report-no_igpu.log.gz (550.3 KB)

Ok, please re-enable the amd igpu and add the kernel parameter

1 Like

thank you for your help and taking your time with this. unfortunately, this also doesn’t appear to have fixed it. i have attached another log of my normal setup with iommu=off and i’m also attaching another one with DP-3 unplugged for comparison
nvidia-bug-report-DP-3_unplugged.log.gz (759.5 KB)
nvidia-bug-report.log.gz (511.6 KB)

What I don’t really understand is that DP-3 doesn’t seem to be active, does it display anything?

that is correct and no, it’s usually not displaying anything. a monitor simply being plugged into any of the DP outputs causes these issues. it makes not difference to the lag/high gpu usage issue wether or not anything is actually being output

edit to add: the bios splash screen gets displayed on the DP-3 monitor for some reason, even if it is disabled in the nvidia settings, not sure if that could be relevant